How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53784
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Slk 320: , alarm key didn't work so I opened the car with

Customer Question

Hi, alarm key didn't work so I opened the car with the blade key. Alarm went off. Tried starting car and it won't start now. Alarm keeps going off if I try to open the glove compartment or lock the doors.
Submitted: 2 years ago.
Category: Mercedes
Expert:  Marty replied 2 years ago.
Hi, welcome to Just Answer, my name is***** sounds like your battery is weak. Try connecting a jumper battery to your battery and see if it will start. When the battery dies the alarm still works because the alarm has a separate battery inside the alarm siren.
Let me know what you find out.
Marty
Customer: replied 2 years ago.
Hi Marty, it isn't the battery. The lights turn on and the radio is on...it seems it's the tow sensor?
Customer: replied 2 years ago.
I think I need to reset the towing sensor?
Or is it the PSE?
Customer: replied 2 years ago.
I tried to disarm the car alarm by putting the key in the ignition. I think it tripped the towing sensor....
Expert:  Marty replied 2 years ago.
Hi, if the battery is good the next most likely fault is the PSE module. Since the locks don't work I'd say the module has probably failed. The PSE module also disarms the alarm system.
Customer: replied 2 years ago.
What can I do to turn the alarm off and start the engine again?
Customer: replied 2 years ago.
Better question is how do I get to the PSE module to disarm the alarm. And doing so will the engine start?
Did the towing sensor go off that is why the engine is locked?
Expert:  Marty replied 2 years ago.
You can't do either if the PSE has failed. You can inspect the PSE and see if the connector is corroded. If you clean the connector you might get it working. Aside from that the PSE will most likely need to be replaced. Fuse 25 and 26 power the PSE. You should check them to see if they are bad. If the fuses are good and the battery is good there is not much you can do aside from inspecting the PSE to see if there is any corrosion on the plug. The towing sensor is not the problem. The PSE is located in the bottom of the trunk on the passenger side. You will need to remove the floor covering to access the pump. The pump is located in a foam box on the passenger side. Usually moisture finds it's way to the pump and damages it.
Let me know how you make out.
Marty
Customer: replied 2 years ago.
Hi Marty,
No corrosion or water issues. Looks fine. Need to tow it to figure out what the issue is. How do we disable the alarm to be able to tow it?
Expert:  Marty replied 2 years ago.
I'd still try a jump start just in case the voltage is low. The only way to silence the alarm if you cannot turn it off with the remote or by turning the key in the ignition is to remove the alarm siren from the car. If the jump doesn't help and if the central locks don't work at all I still think this is a PSE problem. I can send you instructions for removing the siren if you need them.
Expert:  Marty replied 2 years ago.
Hi, I'm just following up with you on the Mercedes. Was my answer helpful?
Marty