How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask promerc Your Own Question
promerc
promerc, mercedes diagnostic technician
Category: Mercedes
Satisfied Customers: 563
Experience:  Qualified mercedes diagnostic technician & service team manager , ATA registered Master tech
13433296
Type Your Mercedes Question Here...
promerc is online now
A new question is answered every 9 seconds

2002 ML320: Power on, code is fine - NO SOUND at all.

Customer Question

I have an 2002 ML320 with Bose stereo. Took stereo out for a day and out back in. Power on, code is fine - NO SOUND at all. What could it be?
Submitted: 5 years ago.
Category: Mercedes
Expert:  promerc replied 5 years ago.

promerc :

welcome to just answer , if the head unit is working as normal , it could be the orange fibre optic cable isnt inserted corectly or not at all , the sound is transmitted along these cables

Customer : Fiber optic cable is attached, any other ideas
promerc :

the head unit is the master on the fibre optic circuit , if this is ok you need to check it is ok at the bose amplifier which is under the passenger seat , disconnect here turn on the radio and look at the cable you should see red light if so and it still dosent work the optical ring must be restarted and to do this the car must go on a mercedes star diagnosis machine