How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Stan Your Own Question
Stan, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3526
Experience:  Technical support engineer
Type Your Mercedes Question Here...
Stan is online now
A new question is answered every 9 seconds

Multi function relay? (1997 Mercedes Benz C280 - Kaehler Relay)

This answer was rated:

where is the multi function relay? (1997 Mercedes Benz C280 - Kaehler Relay)



Please look at the picture below. This is K40 relay module.

Best Regards,



Just to make sure we are on the same page here because there are two relay modules, could you describe which functions are controlled by the relay you are asking about?

Does your car have a mechanical or electronic ignition key?

Customer: replied 7 years ago.
This is the relay for the wipers and the turn signals. At times the wiper comes on when it wants to. The turn signals work sometime and sometimes they do not. It appears that these items are covered by the multi function relay. Unfortunately the diagram that I once used does not indicate clearly where it is. It appears it may even be in the trunk.

Thank you for clarifying. To access it, you will need to remove the front left fusebox cover. Below is the picture of it. 97 was a model change year, let me know if you see a bit different picture. But the location of combination relay was unchanged. Quite often the problem described is caused by cold solder joints on the electrical plates of the relay, so a good soldering job might solve the issue.

Best Regards,



Customer: replied 7 years ago.
I am sorry for the delay. I will try to look for it today.
Customer: replied 7 years ago.

Again, sorry for the delay. I have taken a look at it. I am guessing it is the one that looks lilke the one in the picture. It does not have N10 on it. There are 3 other relays in there. 2 are smaller and square and the other one is held in place by a bracket kind of thing.

I do not see any problems with the posts on the relay.


Would a faulty relay be the likely cause if the wiper turned on by itself and the turn signals worked every now and then. By the way the wiper will sometimes come on when I start the car. By turning the car off it will then turn the wiper off. Restarting the car seems to fix the problem for that period of driving. At other times I have been driving and all of the sudden the wiper just starts, well, wiping. Again, turning the car off and restarting makes it stop.

Thank you.



Hello Michael,

The two things these systens have in common are the combination switch and this relay. So it should be the relay's fault if the switch has no effect on the problems. It will not have N10 written on it. If in doubt, remove the relay and then switch on turn signals and wipers, they will not function with the relay out.

If you have friend who deals with electronics, tell him that you mostl likely have a cold solder issue in the multi-functin relay, and he will know what he needs to resolder. The relay must be taken apart for this, you will not see any damage unless it is disassambled.


Best Regards,


Stan and other Mercedes Specialists are ready to help you