How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, Shop Foreman Freightliner trucks
Category: Medium and Heavy Trucks
Satisfied Customers: 4962
Experience:  Shop Froeman for Freightliner Trucks
3506196
Type Your Medium and Heavy Trucks Question Here...
roybelding is online now
A new question is answered every 9 seconds

I have a 2007 Freightliner Columbia...was just up in the

Customer Question

I have a 2007 Freightliner Columbia...was just up in the snow and salt...now my high beam headlights don't work!..or my wiper unit, or my
JA: What is the complete model and serial number of your machine?
Customer: Freightliner Columbia 1FUJA6CKX7LX83508...high beams, wiper unit and heater/ A/C fan not operable
JA: Anything else you want the equipment mechanic to know before I connect you?
Customer: That's it
Submitted: 1 month ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 1 month ago.

hello, my name is ***** ***** I will be glad to assist you. please allow me a couple of minutes to gather some basic info.

Roy

Expert:  roybelding replied 1 month ago.

have you checked all fuses in the fuse block for power on both sides???

any recent work??

Roy

Customer: replied 1 month ago.
how do I check fuse block for power to both sides?...Under right side dash cover is a fuse box that seems to have all good fuses...The problem is intermittent as well, some times the circuit works for a minute then quits again
Expert:  roybelding replied 1 month ago.

with a volt meter.

yes, that is the fuse box. there may also be one behind the drivers seat.

also, check the batteries. look for any corrosion around the cables. there may be some wiring with in line fuses coming off that area. be sure the connections are clean and tight

Roy

Customer: replied 1 month ago.
ok..will check that in the a.m. Thx for now Roy
Expert:  roybelding replied 1 month ago.

your welcome

Roy

Customer: replied 1 month ago.
Roy...just checked connections nd cleaned battery... Checked fuses and all is good... I suspect a bad ground wire for circuit but where that
Expert:  roybelding replied 1 month ago.

most grounds go back to the battery. there are some in the truck. check the headlight switch itself for the connector having bent or damaged pins. I believe there is a ground on or under the left or drivers side at the computer connector. check either on the floor or back at the firewall.

Roy

Customer: replied 1 month ago.
Roy... Just checked hot wires to high beams, wiper motor and A/C Heater control. Theres week current to each... All other circuits / fuses are good... What now??
Expert:  roybelding replied 1 month ago.

you have a wiring harness issue. probably on the power side. it could be inside or outside the truck. this will take time to trace down. start at the fuse block and work your way out to the lights.

Customer: replied 1 month ago.
Well. .. I have access to the harness of A/C Heater control... Main connector block checks week current at orange wire and week at green wire... They are twisted around each other but I need wire diagram to know where to find there link to battery... Help
Customer: replied 1 month ago.
Is the A/C Heater Control Board bad???
Expert:  roybelding replied 1 month ago.

thats the network communication.I believe in 07 it was 1587. it starts at the connector for the nexus and goes to each module in the truck. it is the way they communicate.

I doubt all the pieces that do not work are bad. you have a voltage feed issue which is most likely in the harness

Roy

Customer: replied 1 month ago.
Instead of looking thru each harness... Is there a voltage reading I should have at the orange wire... and what voltage at the green wire..?? I would like to see that the Controlboard ofA/C Heater Unit is functioning??
Expert:  roybelding replied 1 month ago.

on communication networks, there should be no voltage. you measure resistance of the network harness.

with a harness issue, you will need to look at the harness. no short cuts on harness issues

ac wiring attached

Expert:  roybelding replied 1 month ago.

do you still need help

Customer: replied 1 month ago.
No Roy...went back to the Fuse/Relay Box and found a bad Acc Relay that was hidden in a tight corner...Thanks
Expert:  roybelding replied 1 month ago.

ok

Roy

Related Medium and Heavy Trucks Questions