How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask go-west.. Your Own Question
go-west..
go-west.., Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 1173
Experience:  Technican with 20 years experience focused on engines and electrical.
35815791
Type Your Medium and Heavy Trucks Question Here...
go-west.. is online now
A new question is answered every 9 seconds

I have a 2005 Freightliner M2 Sportchassis with a C7 cat

Customer Question

I have a 2005 Freightliner M2 Sportchassis with a C7 cat engine. My Tac, Speedometer, oil pressure, water temp, and volt meter is not working. I am getting no eng, no j1587, no abs.
JA: What is the complete model and serial number of your machine?
Customer: I'll get back to you with that.
JA: Anything else you want the equipment mechanic to know before I connect you?
Customer: 1FVAFCDD05HU62685 M2106
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Customer: replied 2 months ago.
The truck runs. I have tried a different ICU and a different bulkhead. Didn't fix the problem. Check fuses.
Expert:  go-west.. replied 2 months ago.
Good evening
Yes that message that your are getting means the truck data link is shorted out and the vehicles ecu's are not talking to one another thus the message you are getting on the dash, whats causing the issue? Well the most common issue is the chassis module, this module is mounted on the frame left side midship.. Usually just behind the cab, it has 5 connectors unplug all those connectors and inspect for corrosion, let me know what you find..
Customer: replied 2 months ago.
Ok. I will check it in the morning. I did notice that the owner before may have replaced it. It appeared to be new.
Expert:  go-west.. replied 2 months ago.
Like brand new?
Customer: replied 2 months ago.
Not getting any fire at the body control unit
Customer: replied 2 months ago.
I found a blowed fuse by the batteries. When I unplug the top right plug in the body control unit the gauges work. When I plug it in it blows the fuse and they stop working.
Expert:  go-west.. replied 2 months ago.
Are you talking about the bhm module at the firewall,? If so please tell me the plug number, the numbers should be cast into the module..
Customer: replied 2 months ago.
The chassis module. C3
Expert:  go-west.. replied 2 months ago.

perfect

https://www.dropbox.com/s/7cfiu3try44ptxj/m2%20c3.pdf?dl=0

have a look at the link

that fuse at plug c3 is for the following outputs on the link,you have to remove 1 wire at a time and see what wire is popping the fuse..once you find the wire we will take it from there,let me know how you do..

Customer: replied 2 months ago.
I didn't get to look at the diagram but I did what you said earlier today and drove the truck 500 miles tonight and everything was fine. I found the J1587 wires that are twisted together (green wire and orange wire). I cut the green wire, plugged in C3 and everything is working fine except for the fuel gauge works 3/4 of the time. Mainly while driving it is working but when I stop it stops. Also, I can plug into the ecm inside the cab and read all the engine information now.
Expert:  go-west.. replied 2 months ago.
Good show
Will you leave it then or do you have any other questions?

Related Medium and Heavy Trucks Questions