How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1637
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I had asked a question last month regarding my 2005 E450

Customer Question

I had asked a question last month regarding my 2005 E450 Cutaway box truck. The problem is that when you shut off the ignition switch the engine shuts off but the accessories (radio, warning lights on dash, etc.) stay on, which in turn run the battery down. A local shop had initially replaced the ignition switch, this did not correct the problem. I then asked for help on Just Answer where it was suggested that the battery saver relay in the instrument cluster had gone bad. This lined up with the thoughts of my local shop so they located a used instrument cluster which was installed. The same problem still existed. I have a hard time thinking that the same issue existed in the used cluster. I have since just been unhooking the battery cables after each use. Does anybody have any more ideas?
Submitted: 1 month ago.
Category: Medium and Heavy Trucks
Expert:  david craig replied 1 month ago.

Hi Im David, please allow me a few moments to come up with a resolution to this ongoing issue. thank you.

Expert:  david craig replied 1 month ago.

a couple thing to try before we get too heavy into stuff. check the operation of the door switches. also pull the trim off down at the bottom driver side door sill, and there should be ground wires there. make sure they arent all corroded and or broken. let me know

Customer: replied 1 month ago.
The door switches seem to be working fine. I looked under the kick plate and see a large black cable runnning from under the truck through the floorboard. I thought maybe it had rubbed through the insulation and was grounding to the cab, but I moved it around and the accessories still stayed on. Other than that I see a lot of wires in harnesses. Can't tell for sure but I don't see any obvious problems.
Expert:  david craig replied 1 month ago.

pull the trim off along the bottom door sill and look for ground wires.

Customer: replied 1 month ago.
I did that. This is where I saw the large black cable coming through the floorboard and wire harnesses.
Expert:  david craig replied 1 month ago.

how about behind the kick panel up under the side of the end of the dash?

Expert:  david craig replied 1 month ago.

find anything yet?

Customer: replied 1 month ago.
Sorry, haven't had a chance to look into it further. I hope to tomorrow.
Expert:  david craig replied 1 month ago.

ok,thanks

Expert:  david craig replied 1 month ago.

any luck?

Expert:  david craig replied 1 month ago.

hello?????????

Related Medium and Heavy Trucks Questions