How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 3279
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

I'VE GOT A 2014 FORD F-750 WITH A CUMMINS ISB. HAD A CHECK

Customer Question

I'VE GOT A 2014 FORD F-750 WITH A CUMMINS ISB. HAD A CHECK ENGINE LIGHT ACTIVE CODE 0241 FOR THE VEHICLE SPEED SENSOR. FOUND THE TRANSMISSION WIRING HARNESS MELTED. WE REPLACED THE TRANSMISSION WIRING HARNESS AND VEHICLE SPEED SENSOR. CEL KEEPS COMING ON WITH SAME CODE. AUTOMATIC TRANSMISSION. WE NEED A WIRE DIAGRAM AND ANY HELP WITH ACTIVE CODE. THANK YOU.
Submitted: 8 months ago.
Category: Medium and Heavy Trucks
Expert:  david craig replied 8 months ago.

Hi Im David, you sure you have the right code??? P0241 FORD - Turbocharger/Supercharger Boost Sensor 'B' Circuit Low ..... Possible causes - Boost pressure sensor harness is open or shorted - Boost pressure sensor circuit poor electrical connection - Faulty boost pressure sensor - Faulty Turbo/Super Charger - Engine over temperature - Ignition misfire exceeds the calibrated threshold - Faulty Knock sensor (KS)

Customer: replied 8 months ago.
sir
I have the print out in front of me.
0241 Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect
Customer: replied 8 months ago.
sir
I have the print out in front of me.
0241 Wheel-Based Vehicle Speed - Data Erratic, Intermittent, or Incorrect
This is from Cummins Insight
Expert:  david craig replied 8 months ago.

well them my book are either wrong or theirs are. let me research a bit

Expert:  david craig replied 8 months ago.

ok found it. follow these troubleshooting steps

http://ww2.justanswer.com/uploads/JCTech012/2009-11-13_110739_FC241.pdf

Customer: replied 8 months ago.
Thank you David
This the one we have from Cummins, it is the wrong schematic, this truck doesn't have an adjust speed sensor. the wires goes to trans ecm. then we are not sure which wires goes to come out of trans ecm and goes to engine ecm. we had to replace trans wire harness, all the wires were melted together, from not covered up from the heat when regeneration.
Expert:  david craig replied 8 months ago.

ok. let me check something else

Expert:  david craig replied 8 months ago.

http://wfservices.biz/Manuals/ISB_TROUBLESHOOTING_VOL_2.pdf

Customer: replied 8 months ago.
Thanks David that is the same schematic that you just sent us.
we already replaced speedometer sensor too, the sensor is a push in, bolted down, the new speedometer doesn't have the ohms the test show, put the test shows a different one. we are going to order another one, just to make sure.
have you been able to pull up a wire diagram from the ford side of ecms
Expert:  david craig replied 8 months ago.

Im going to hand this off to another tech. sorry i couldnt have been more help. i dont have a pinout of the ecm for that year.

Expert:  Jeremy replied 8 months ago.

My name is ***** ***** I will assist you with your question today.

I'm an independent contractor and I don't get paid until a rating has been made.

We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence!

Which diagram are you needing? Do you have a 2000 or 3000 series in this truck? Ford used both on these models. That is if you have the Allison. They also used the Torqushift on them as well. Let me know what you need so I can pull the right ones from Ford for you.

_______________________________________________________________________________

You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see, touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback, they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 8 months ago.
2000 series Allisson
Customer: replied 8 months ago.
diagram speedometer sensor to trans ecm back to engine ecm. we have engine code 0241. we've replaced the speedometer sensor on transmisson, and found the transmission wiring harness melted from the dpf heat.
Customer: replied 8 months ago.
We put installed a new transmission wire harness. code came back.
Expert:  Jeremy replied 8 months ago.

Have you worked with a CAN BUS system before? How this works if the signal goes from the speed shaft sensor to the TCM. From there, all the signals are sent on 1 wire through the CAN BUS network to the ECM, Cluster module, etc. With the Allison 2000, it send the signal on the CAN BUS, not a individual circuit to the cluster. If you are getting the code P0241, youe most likely have an issue between the TCM and the Shaft Speed Sensor.

There is one exception, the TCM does have a VSS direct wire that goes to the ECM. In the engine diagrams, the fist page, you will se that. That is most likely the wire that is giving you a fault. If you test it and it tests goos, then use a laptop and update the modules and see if the error will clear out. There could be a communication problem on the modules that needs to be reset/recalibrated (this is automatically done during a flash event) to resolve the code. This is if everything else on the wiring tests to be good and you are getting a low ohm drop out on the links.

I am loading all the diagrams into this folder. CLICK HERE

Customer: replied 8 months ago.
Thank you
We will check it out in the morning
Expert:  Jeremy replied 8 months ago.

You're welcome.

Let me know what you locate.

Customer: replied 8 months ago.
Will do
Expert:  Jeremy replied 8 months ago.

Thanks.

Customer: replied 7 months ago.
The wire diagram showed for a manual shift, wire was not in engine ecm for speedometer, that showed on diagram. We decided to go with your suggestion, to have it flashed, sent to Ford dealer to have it done, will let you know how it goes.
Expert:  Jeremy replied 7 months ago.

Hopefully the flash will take care of the issue. For some reason, it tends to take care of a lot of data issues.

Customer: replied 7 months ago.
Just picked up truck from dealer, will let you know how it does
Thanks
Clay
Expert:  Jeremy replied 7 months ago.

Sound good.

Customer: replied 7 months ago.
customer has had the truck since we picked it up,issue seems to have been solved! Thank you.
Customer: replied 7 months ago.
Take that back, he just came and said it was doing the same thing again
Customer: replied 7 months ago.
The wire harness you sent, showed a manual transmission not an automatic Allison, wires didn't match up. Do you mind checking again.
This truck does have a pto on it for the boom ladder.
Expert:  Jeremy replied 7 months ago.

The diagrams I sent showed only a automatic transmission. There are no manual transmissions for the 2014 model. Only the Allison 2000 and 3000 models. There is also the Ford Torqshift, but I only supplied the Allison ones.

Since you stated it didn't match up, I removed them.

I am going to also opt out since those were the only ones available on the Ford site and you tried the only options I would do.

I do hope you get this resolved.

Good day.

Related Medium and Heavy Trucks Questions