How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8630
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

We have a 05 t300 with an avert c7 that starts and runs fine

Customer Question

We have a 05 t300 with an avert c7 that starts and runs fine but when driving randomly looses power like a dead pedal. Sometimes it sputters upon start up
Submitted: 5 months ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 5 months ago.
Thanks for asking your question. I will try and help you out.
Does the yellow check engine light come on while driving?
Customer: replied 5 months ago.
There is no check engine light on and no codes when hooked up with my pro-link ultra. injection control pressure is bouncing between 1300 and 1500 psi as well
Expert:  Cat Man replied 5 months ago.
Thanks for the information.
Unfortunately I have seen this many times. I would suspect a low fuel pressure problem.
If there is a low fuel pressure problem, the check engine light will not come on and the engine will have low power. Your engine should maintain a fuel pressure between 65 and 85 psi. There is a plug beside of the secondary fuel filter that is used to check the pressure. If it is low, I would first try the fuel filters if you haven’t already. If it is still low, you may have a failed fuel pressure regulator, which is located on the back of the cylinder head. I have replaced a ton of these for low fuel pressure. It is kinda a known problem. You could also have a weak fuel transfer pump or restricted hand primer pump, if your engine has one.
Also, a faulty fuel pressure regulator will also cause fuel to leak down when the engine is off which makes the engine run rough at start up.Please reply back if you need more help or have more questions. I am happy to assist.
Customer: replied 5 months ago.
Fuel filters have already been changed out. I tested fuel pressure and it idles around 62 psi, then with the truck off and gauge still connected the pressure starts to bleed off really slowly. I'm assuming that this looks like the pressure regulator on the back of the head is the issue
Expert:  Cat Man replied 5 months ago.
Thanks for the information.
Yes I would first suspect the regulator. I would try changing it first.
Please reply back if you need more help or have more questions. I am happy to assist.
Expert:  Cat Man replied 5 months ago.
Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.

Related Medium and Heavy Trucks Questions