How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8419
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

2007 c13 seems to be losing power in pedal at top speeds.

Customer Question

2007 c13 seems to be losing power in pedal at top speeds. Power seems to kick back in after about 5 seconds but problem keeps occurring. I changed pedal sensor but it still happens
Submitted: 1 month ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 1 month ago.
Thanks for asking your question. I will try and help you out.
Does the yellow check engine light come on when this happens?
Customer: replied 1 month ago.
Not every time
Expert:  Cat Man replied 1 month ago.
Thanks for the information.Since the check engine light does not come on, I would suspect 1 of 2 things are causing your problem.The first is low fuel pressure. If there is a low fuel pressure problem, the check engine light will not come on and the engine will have low power. Your engine should maintain a fuel pressure between 75 and 90 psi. There is a plug beside of the secondary fuel filter that is used to check the pressure. If it is low, I would first try the fuel filters if you haven’t already. If it is still low, you may have a failed fuel pressure regulator, which is located underneath the bottom of the filter housing. I have replaced a ton of these for low fuel pressure. It is kinda a known problem. You could also have a weak fuel transfer pump or restricted hand primer pump, if your engine has one.Second I would suspect you have a low boost condition. This can be caused by a leak in the air piping or air to air aftercooler on the truck. I would first inspect all of the piping to see if there is a hole in any of the rubber boots that hold the pipes. From there you may want to cap off one side of the air to air cooler, and pressurize it. They have been known to crack and leak and cause low boost.Please let me know if you need more help or have more questions.
Customer: replied 1 month ago.
Thanks! I also cleared fault codes. However one did not clear: 111-15 engine, coolant level High Severe (1). Would that have any effect?
Expert:  Cat Man replied 1 month ago.
As long as it is not active it will not affect the engine. However if it's active it can derate the engine.
If the coolant level is full and you get this code. You most likely have a faulty sensor. I see this a lot.
Expert:  Cat Man replied 1 month ago.
Please reply back if you need more help or have more questions. I am happy to assist.
Expert:  Cat Man replied 1 month ago.
Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.

Related Medium and Heavy Trucks Questions