How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 2784
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

I have a 2011 Ford F-750 6.7isb with Allison 3000

Customer Question

I have a 2011 Ford F-750 6.7isb with Allison 3000 transmission. I have the "cat eyes" on the display. I drove it 1000 miles a month ago, went to move it 2 weeks ago and display was doing goofy stuff like it was booting up then cat eyes then N N then cat eyes. Moved it but now it will show only cat eyes and I'm stuck I have checked fused and seems they are all good and I replaced fuses to be safe. I just can not move it and it's in middle of our lot.
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 2 months ago.

My name is ***** ***** I will assist you with your question today.

I'm an independent contractor and I don't get paid until a rating has been made.

We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence!

to understand, you start it and it doesn't show a gear at all or you can't even start it?

_______________________________________________________________________________

You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see, touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback, they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 2 months ago.
Hey Jeremy, it won't start because it's not seeing N N on gear display. It will just show the "cat eyes". It's from I read lost communication with the Transmisson.
Expert:  Jeremy replied 2 months ago.

Push the up and down arrow at the same time to see if you get the codes on the display. This will let you know if you are connected to the transmission and you are getting a fault in the display unit itself or if there is a harness issue in between.

That looks like the older style displays that Allison had a recall on for that issue so I suggest contacting Allison with the VIN to see if that is part of the recall. The new ones have the Allison wording that is raised with white and the older ones is all black like yours is.

Definitely see if there is communication. Those symbols do mean there is a communication loss. The problem is determining if it is a power loss to the transmission ECU or if there is another loss issue. Do you have the Allison software to connect and control the transmission to see that the TECU is actually communicating?

Customer: replied 2 months ago.
Hey Jeremy,
I tried hitting the up and down button together and it goes blank no code. The only thing that is lite up is the mode red light. I don't have anything to communicate with Allison that I know of. What would I need? Thanks again
Expert:  Jeremy replied 2 months ago.

It will be the Allison DOC software to communicate with it.

With you not getting any codes, there is no communication between the transmission ECU and the display unit. Do you have another truck that you can borrow the unit from? This will rule out a display problem. That display is a module of itself. It has a plug in the back where the display unplugs then plugs back in. No programming is needed for them. They just plug in and work.

If you swap and it is a no go, then chasing will need to be done to make sure you have power getting to the transmission ECU since you don't have the Allison software and a reader to plug into the truck. It will be a task to take on and a lot of chasing to do. I just want to forewarn you.

Customer: replied 2 months ago.
I had a guy stop by with scanner this is what it said
Expert:  Jeremy replied 2 months ago.

The 2003 code is com loss between ECM and TCM.

The 2011 code is loss of data with ABS module.

That tells me there is a harness issue for the back bone aka the main harness that links all the modules together.

Customer: replied 2 months ago.
I checked the harness from the engine plug to the tcm and ran 12v and everything passed. Then checked power at tcm and it passed as far as I can tell. Would you check the the harness coming out of ecm on left side of engine to where the tcm meets? I'm again new to these f-750s and they are totally diffrent then I'm used to. I didn't know if you have access to any sites that people have complained of connection somewhere or anything? Any recommendations are awesome thanks again
Customer: replied 2 months ago.
What I meant by engine plug it's about 16 in from the ecm and I was told that a lot of times from that connector to the tcm wires wore which on this one it did at one point but it's been fixed already and the connections were good.

Related Medium and Heavy Trucks Questions