How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4669
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

There I have a 2005 freightliner motorhome with ISB 300, low

Customer Question

hell there I have a 2005 freightliner motorhome with ISB 300, low on power error codes as shown on info display
Fault 1 of 1
Engine Coolant TEMP
SPN 110 CM 0
Data Valid But Above
Normal RNG
Fault 1 of 1
Var GeoTurbo
SPN 641 CM 0
Current Open OR
Below Normal RNG
FMI 5 OC 127
can you tell me what this means, I removed turbo checked actuator motor, actuator sensor with oscilloscope, turbo speed sensor has square wave pulse at low speed turning by hand but if i spin it fast, square wave goes to gnd is this normal. thanks John
Submitted: 5 months ago.
Category: Medium and Heavy Trucks
Expert:  go-west.. replied 5 months ago.
Good evening
May I have the engine serial number please
Expert:  go-west.. replied 5 months ago.
Good afternoon
Were you able to get the info?
Expert:  go-west.. replied 4 months ago.
Good morning
I'm here if you need help.
Customer: replied 3 months ago.
Hello there you asked me for the serial number to engine it is........esn57346380 thanks
Customer: replied 3 months ago.
ok
Expert:  Daniel Wilson replied 3 months ago.

Hi my name is Dan. 110 will derate and shut down your engine.... Either an overheat problem or faulty sensor or harness for the sensor.

151 Engine Protection

P110 0

110 0

Coolant Temperature Too High

641 is for the VGT actuator. Possible wiring or faulty actuator or out of calibration

Expert:  Daniel Wilson replied 3 months ago.

The actuator needs recalibration on installation with Cummins Insite.

Customer: replied 3 months ago.
actuator motor had low im pedance 10 ohms and had resistance to ground i replaced it rest of turbo was great customer drove 500 miles no prob now same code again im going to test see if its bad again is this common?
Expert:  Daniel Wilson replied 3 months ago.

Was it calibrated with Insite? it should not fail that soon . Not common but parts defects are possible. Id try recalibration again and see if it resolves.

Customer: replied 3 months ago.
No i never calibrated it just installed is that ,that critical it did go 500 miles no prob i dont have insite .
Expert:  Daniel Wilson replied 3 months ago.

Thanks for the update. It does need to be calibrated any time it is remove or replaced.

Related Medium and Heavy Trucks Questions