How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4402
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Ok went back to work on truck international 4300 with 6.0

This answer was rated:

Ok went back to work on truck international 4300 with 6.0 found a leak on hpop and fixed it. Started right up and ran fine went around the block and got back no start again. No chatter from ficm i do have all powers and grounds to ecm but no start.

Hi, It's Dan. Will Diamond logic read /communicate with the ECM? Check and verify your ICP pressure is still in specs , unplug the ICP sensor to see if it will start in default status and if so replace the sensor if the pressure is in specs. Check for RPM signal from the cam/crank sensor as without it the injectors wont fire. Let me know.

Customer: replied 2 months ago.
Diamond logic is communicating with truck icp pressure is within spec i pulled the ico connector and still no start put a gauge on it and got up to 2500 psi got also rpm signal from both cam and crank sensor.

Interesting. With 12 V on the IPR will HPOP reach 3500-4000 psi as it should?

Is fuel pressure in specs?

Customer: replied 2 months ago.
ipr reaches max oil psi fuel psi is 55

But no start even when unplugging the ICP sensor.... If there is definitely fuel and good ICP, crank and cam sensor signal and no fault codes it points to a possible failed ECM. Have yours reflashed and bench tested or see if you can find a good one for a test ECM to use.

Customer: replied 2 months ago.
Ok let me search for one.
Customer: replied 2 months ago.
yeah there is no chatter from injectors with the key on and power comes from ecm to idm to power injectors.

Verify the ECM power and grounds are good and switched power. If so it looks more like an ECM/IDM issue.

Customer: replied 2 months ago.
Ok

Pleasure to help

Daniel Wilson and other Medium and Heavy Trucks Specialists are ready to help you

Related Medium and Heavy Trucks Questions