How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4394
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have a 2013 4300 with a dt466 it's the new regen engine. I

Customer Question

I have a 2013 4300 with a dt466 it's the new regen engine. I have a misfire on #4 injector. I have replaced injector, cleaned out high pressure oil valve body, replaced valve cover harness, and it still has misfire with a code. It is driving me crazy.
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 2 months ago.

Hi Randall. My name is***** the injector is new and compression is good and no restrictions of fuel and oil to the injector it has to be a problem in the wire harness or ECM itself. I would take a very close look there. Let me know

Expert:  Daniel Wilson replied 2 months ago.

The ECM is the only thing left. Possible faulty injector driver

Customer: replied 2 months ago.
I checked the ECM and wiring it's all good. My injector #4 fault is now in healing mode. I was wondering if on these internationals if an injector is still missing some that it might not throw a code. I think it's still missing on a cylinder. It sounds like it anyway but I have no more injector codes.
Expert:  Daniel Wilson replied 2 months ago.

Thanks for the update. It is possible for an injector to have a mechanical problem and not throw a code. You would need to do an injector and cylinder test using the international diagnostic software Service maxx to troubleshoot this further and determine if there is still and actual problem. You could also reflash and update the ECM software to the most current updates and see if it helps the engine run smoother. Let me know

Related Medium and Heavy Trucks Questions