How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4377
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I was driving it down the road at 70 mph and it just shut

Customer Question

I was driving it down the road at 70 mph and it just shut off like you would have turned the key off
JA: What's the make/model/year of your truck? Engine type?
Customer: 2007 international 7300 w dt466
JA: Are you fixing your truck yourself? What have you tried so far?
Customer: yes. tried retrieving codes using cruise buttons and none will come up but the check eng light is on
JA: Anything else you want the truck mechanic to know before I connect you?
Customer: no
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 2 months ago.

Hi my name is***** will be glad to try to help...Try this procedure to retrieve your codes. check to see if the tach is responding while cranking as a failed cam sensor is a very common cause of this. click below and let me know what you get for codes.

Fault codes

Customer: replied 2 months ago.
2033 14p
Customer: replied 2 months ago.
far we have changes icp,ipr,cps,
Checked fuel pressure at the filter housing scrader.. Still no start..
Customer: replied 2 months ago.
the tac is working while cranking and there is 40 psi oil press
Expert:  Daniel Wilson replied 2 months ago.

Thanks for the update. With the ICP sensor unplugged the ecm should go to default settings and see if it starts. should be around 870 psi at the ICP sensor port with a 5000 PSI guage in the ICP sensor port while cranking and up to over 4000 PSI with 12V at the IPR while cranking. Pressure test with shop air at the ICP sensot port to listen for air leaks under the valve cover indicating injector o ring leaks. Let me know

Expert:  Daniel Wilson replied 2 months ago.

Verify ECM power and grounds and also check the IDM relay and wiring harness.

Expert:  Daniel Wilson replied 2 months ago.

Click this link for further troubleshooting

Troubleshooting