How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8415
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

I have a 04 KW t800 tractor with c13 egine. Yesterday while

Customer Question

I have a 04 KW t800 tractor with c13 egine. Yesterday while empty the engine spottered then eventually lost power and shut down. I replaced the water separator and fuel filter but it failed to start unless I sprayed starter fluid into the air cleaner. When that is done it will run for a few seconds or sometimessage a few mintestinal and shut down. I replaced the primer pump and fuel check valve at the filter and no difference
Any ideas what it could be? Btw there is no check engine light on
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 2 months ago.
Thanks for asking your question. I will try and help you out.Does the yellow check engine light come on when the key is turned to the on position?
Customer: replied 2 months ago.
the check engine light will appear when the key is turned on but, goes off when the engine is running (even when starter fluid is used).....Above should read...When that is done it will run for a few seconds or sometimes a few mintes and shut down.
Expert:  Cat Man replied 2 months ago.
Thanks for the information.Since the yellow check engine light comes on, this indicates the engine ECM is receiving power and functioning. There are several things that can cause a crank no start on this engine.The first is a low or no fuel pressure condition. The engine needs at least 35 psi to start. If it is low, the injectors will not get filled and it will not start. If the engine has a hand priming pump, and it gets stiff when operating it, the engine has enough pressure to start. If there is no hand priming pump, I would connect a psi gauge and measure the pressure. If the pressure is low, I would change the fuel filters first if you haven’t already. If it is still low, I would suspect a failed fuel pressure regulator in the secondary fuel filter housing, a weak fuel transfer pump, or restricted fuel inlet line. The pump is located on the front of the engine.Second is a failed engine speed timing sensor. Some engine have one, some have two. It depends on your engine serial number. If the engine speed timing sensor has failed, the ECM gets an RPM/TDC signal and will not send AC to the injectors.Next is low battery voltage to the ECM while cranking. The ECM must have at least 7.5 volts DC to operate. I have seen weak batteries or a poor connection cause low voltage. You could have a poor connection at the batteries or starter.Next is a faulty engine ECM. The ECM has an injector driver module inside. This is what powers the injectors. If it fails, the ECM will log injector codes for all the injectors.Lastly are worn injectors. Over time the injectors can wear if they have a lot of hours on them. To verify, I like to check AC to the injectors while cranking. You should have between 20-40 AC while cranking. If you do, and you have good fuel pressure, the injectors are worn. If you do not have 20-40 AC while cranking, you have either a failed engine speed timing signal, low power to the ECM while cranking, ot a failed ECM.Most often when these things are happening there will be diagnostic codes in the ECM. If your engine has cruise control switches, you can pull the codes. If you have never done this, let me know. I can get you the procedure.Please reply back if you need more help or have more questions. I am happy to assist.
Customer: replied 2 months ago.
When I prime it, the primer does get stiff, and sometimes it will start and run for a short time and shut off. When I check the filter (water separator) is usually low with fuel, could this be an indication that the pump is not maintainin or pushing enough prsssure
Expert:  Cat Man replied 2 months ago.
Thanks for the information.
Yes I agree. It sounds like the fuel transfer pump is the problem. I would consider replacing it

Related Medium and Heavy Trucks Questions