How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1598
Experience:  Owner at DJ Wilson
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Mack Engine E7-400 last drove ran great,start up following

Customer Question

Mack Engine E7-400 last drove ran great,start up following day, running but very bad attempted to check firing of injectors individually front of engine to rear - loosen first injector no fuel at injection point to cylinder; second injector loosen no fuel; third injector no fuel
4th injector loosen line have fuel delivery to engine; 5th injector have fuel; 6th injector have fuel
What is the problem with this injection system concerning the 3 injector in the first heah assembly of this engine.
Submitted: 1 month ago.
Category: Medium and Heavy Trucks
Customer: replied 1 month ago.
correction: injectors in the first head not heah
Customer: replied 1 month ago.
did i miss a response from you in regards ***** ***** truck problemthanks
Expert:  Jim replied 1 month ago.

Hi, My name is ***** ***** I will try to help you with this, First I would check fuel pressure coming out of the transfer pump.

If that is ok, next remove the valve cover from the front head and start the engine and see if you have oil squirting out of the engine brake solenoid, if so this will cause your exact issue. please let me know if we need to go further.

Related Medium and Heavy Trucks Questions