How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1634
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

This is for a diesel tech. I have a 99 wstar that had a 500

Customer Question

This is for a diesel tech . I have a 99 wstar that had a 500 hp 12.7 that blew we put in a 96 12.7 from a running truck that had only 200 k miles and ran real well. The engine seems to have good power but smokes on start up only and misses at idle. We have set valves and injectors and checked it three times as well as jakes. Also taken to ecm expert and tried different computer and different programs. Also preformed cylinder kill test with no cylinder showing week at all.we have tried removing single fuel filter and installing a fas system also fuel pressure gauge. Idle 22 psi and up to 85-90 with load no glitches . It did not seem to do this at first but would die sometimes and that turned out to be bad plug at cam sensor. Replaced plug and sensor and no more dieting or code 43. Idle sounds like pop pop pop or old fashion exhaust stack flappers. Could fuel pressure check valve cause this even with good pressure? Or ???
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Expert:  Jim replied 2 months ago.

Hi, I have ran into this once before, If I were you, I would back all the jake brake adjusting nuts out and start it. I can guarantee this is your problem