How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, Shop Foreman Freightliner trucks
Category: Medium and Heavy Trucks
Satisfied Customers: 4847
Experience:  Shop Froeman for Freightliner Trucks
3506196
Type Your Medium and Heavy Trucks Question Here...
roybelding is online now
A new question is answered every 9 seconds

I have an Cummins ISL 9 that is going into regen all the

Customer Question

I have an Cummins ISL 9 that is going into regen all the time. Removed the dpf and doc. Had both cleaned. installed, reset and performed regen. Still no luck. same problem.
Submitted: 5 months ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 5 months ago.

good evening my name is ***** ***** I will assist

is there any codes??

do you have the insite program to monitor temps and knock sensors??

does it complete regen???

Roy

Customer: replied 5 months ago.
Hi Roy,
no codes.
yes, we have insite
yes, it did complete one regen. system shows normal soot levels.
Expert:  roybelding replied 5 months ago.

what were the temps???

what were the knock sensors reading both inlet and outlet???

Customer: replied 5 months ago.
dpf inlet and outlet both temp were over 1050. they showed a differance of only 10 deg.knock sensors? did you mean pressure sensors?
Expert:  roybelding replied 5 months ago.

no, knock sensors. inlet and outlet they register ppm of exhaust

if the dpf is clean the inlet pressure for the dpf should be around .5 or less

Roy

Customer: replied 5 months ago.
ok, on the nox sensors. i guess i missed that. just an fyi, the engine is a 2013. im going to run the eng now to get that reading. please give me a min.
Customer: replied 5 months ago.
i also just cleaned the dpf.
Expert:  roybelding replied 5 months ago.

ok

Customer: replied 5 months ago.
I can't find a pid for a nox sensor. I'm dubble checking now.
Expert:  roybelding replied 5 months ago.

advanced ecm data

Customer: replied 5 months ago.
Ok tks. Give me a second
Expert:  roybelding replied 5 months ago.

ok

Customer: replied 5 months ago.
No data stream in there. Just different filter maintenance and resets. Injector calibration. Don't see any nox pids.
Expert:  roybelding replied 5 months ago.

trying to think. it is there it is on the same screen as the temps and the inlet pressure for dpf

Roy

Customer: replied 5 months ago.
Ok. Data monitor / longer? Checking again.
Expert:  roybelding replied 5 months ago.

ok

Customer: replied 5 months ago.
I have looked for a nox or anything showing in ppm. Can't find anything.
Expert:  roybelding replied 5 months ago.

its there

if the temps are good, the inlet pressure is good, if the knock sensors were an issue it would code, if the def injector was an issue it would code as well

the only thing left is the dpf. I never have them cleaned as they barely get 50

50% cleaned so they are already 50% clogged from the start

Roy

Customer: replied 5 months ago.
What should the pressure sensors read?
Expert:  roybelding replied 5 months ago.

as I stated before, the inlet should be around .5 lbs outlet close to 0

Customer: replied 5 months ago.
Is that at idle? And at what rpm should we check for a set pressure.
Expert:  roybelding replied 5 months ago.

during re gen

Customer: replied 5 months ago.
Ok on the regen. Just an FYI I had the dpf and doc cleaned by Cummins.
Expert:  roybelding replied 5 months ago.

we used too as well. they are the ones who told us about the cleaning process

Roy

Customer: replied 5 months ago.
I get that. Why is the soot load reading normal and the system going into regen?
Expert:  roybelding replied 5 months ago.

what is normal??? what reading do you see

Customer: replied 5 months ago.
the pid in the data loger says normal, no numbers. i have seen it say slightly above normal lowest level.
Expert:  roybelding replied 5 months ago.

ok, I still think the dpf is your issue

Roy

Customer: replied 5 months ago.
ok, sigh. have yoou seen this and did it change when you installed a new dpf?
Expert:  roybelding replied 5 months ago.

yes, I have many times. and yes, it took care of the issue as well.

Roy

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Expert:  roybelding replied 5 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Customer: replied 5 months ago.
No problem. I've pulled the dpf. I think it might be cracked internally. I'll let you know. I may need more help tomorrow.
Expert:  roybelding replied 5 months ago.

ok

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Expert:  roybelding replied 5 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Customer: replied 5 months ago.
Installed a new dpf. Reset no luck. Still calling for regeneration all the time. Any other ideas?
Expert:  roybelding replied 5 months ago.

sorry, traveling all over

are there any codes set???

Customer: replied 5 months ago.
no codes.
Expert:  roybelding replied 5 months ago.

Sorry, been ill for past week.

how long does it take to perform a re gen???