How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask go-west.. Your Own Question
go-west.., Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 1133
Experience:  Technican with 20 years experience focused on engines and electrical.
Type Your Medium and Heavy Trucks Question Here...
go-west.. is online now
A new question is answered every 9 seconds

2005 freightliner Columbia would take start we have 8 new

Customer Question

2005 freightliner Columbia would take start we have 8 new batteries,beware starter ,been ignition Cylinoid it just won't take start was clicking but not now
Submitted: 2 months ago.
Category: Medium and Heavy Trucks
Customer: replied 2 months ago.
won't start ,new starter,new ignition Cylinoid used to click but won't start now
Customer: replied 2 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Help via Email or Text Message. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  go-west.. replied 2 months ago.
Good evening
To do you have power on one side of the solenoid when the key is keyed to the starting position?You have a standard or automatic transmission?
Customer: replied 2 months ago.
it is on the starter or the firewall
Customer: replied 2 months ago.
I have 12 volts to it
Customer: replied 2 months ago.
it is a 2005 freightliner Columbia stick
Customer: replied 2 months ago.
he has 12 volts on it all
Customer: replied 2 months ago.
hello you still with me
Expert:  go-west.. replied 2 months ago.
If you power at one side that's a good startWith the Key turned over if there power at both side of the solenoid. If there is, sounds like there could be a broken wire from the solenoid to starter. Have a look a let me know.

Related Medium and Heavy Trucks Questions