How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1634
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

The shop changed to timing sensor on my 1999 60 series still

Customer Question

Hi ? The shop changed to timing sensor on my 1999 60 series still wont strt and then change fuel pump and prim sstm but no look
JA: We'll do all we can to help. Tell me a bit more about what's going on so the Heavy Equipment Mechanic can help you best.
Customer: Hello
JA: Hello. What seems to be the problem?
Customer: Hi i, own 1999 60 serie detroit yesterday stop running the shop relace 2. Crank sensir locade near air pump compressor but it didn't start now they replace fuel pump and filter but not start
JA: Is there anything else the Heavy Equipment Mechanic should be aware of?
Customer: No
Submitted: 4 months ago.
Category: Medium and Heavy Trucks
Customer: replied 4 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  roybelding replied 4 months ago.

good afternoon my name is ***** ***** I will assist

do you mean the cam sensor for the timing sensor???

was there any codes set>>> did they check the fuel pressure???

was there any issues prior to this problem???

Roy

Customer: replied 4 months ago.
Fuel pressre is low with a new pump is low the you now psi pressure is
Expert:  roybelding replied 4 months ago.

have you checked the check valve in the return line??? it is either at the back of the head or on the left side of the motor. make sure it is not bleeding off all the pressure

Roy

Expert:  roybelding replied 4 months ago.

are you there

Related Medium and Heavy Trucks Questions