How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4398
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

96 pete 379 cruise not working n14 celect plus

Customer Question

96 pete 379 cruise not working n14 celect plus
Submitted: 4 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 4 months ago.

Hi my name is***** will be glad to try to help. Do you have any fault codes logged? Is your speedo, Jake, or Parked PTO high idle working?

Expert:  Daniel Wilson replied 4 months ago.

Check for VSS ( Vehicle speed sensor problems at the rear yoke of the transmission, park brake switch and harness/connector pins for damage on both . Let me know

Jake Troubleshooting

Here is your engine diagram to help with testing your wiring and sensors, and switches.

N14 Torubleshooting

Customer: replied 4 months ago.
Hi. I the speedometer works and the jakes work. But I do not have high idle. I have replaced the sensor at the yoke but these days you know how parts are.
Customer: replied 4 months ago.
also I have no fault codes and the cruise control light comes on in the dash when I turn the switch on.
Expert:  Daniel Wilson replied 4 months ago.

Check the air pressure switches for the park brake/PTO and wiring harness. Click on this link for the chassis schematics to help.

Diagrams

Customer: replied 4 months ago.
ok thanks for the diagram. where are those pressure switches. I just replace the one in the B panel of the dash this evening because it was leaking when the brakes were engaged
Customer: replied 4 months ago.
I think theres another behind the panel around the brake pedal
Expert:  Daniel Wilson replied 4 months ago.

usually they are near the brake pedal and the other is behind the dash near the maxi switches/ park brake switches. Some are on an air manifold on the newer models under the dash towards the drivers side.

Customer: replied 4 months ago.
the park brake switch would cause the cruise to not work?
Expert:  Daniel Wilson replied 4 months ago.

Yes.Cummins Insite is usefull to see the switch status. PTO wont work unless the park brake switch is engaged. Also you need speed sensor signal both engine and road speed. Service brake switch and clutch switch will effect cruise as well along with a possible wiring problem. A scan tool that will read switch status will speed up the troubleshooting process

Related Medium and Heavy Trucks Questions