How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1598
Experience:  Owner at DJ Wilson
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I working in trailer with carrier unit extra,when I put the

Customer Question

I working in trailer with carrier unit extra,when I put the manifold gauges,low side is 200 and high side is the same pressure 200
Submitted: 3 months ago.
Category: Medium and Heavy Trucks
Expert:  Wayne replied 3 months ago.

Hi I'm Wayne

I will help you with this

your pressure readings is this unit off ??

or running

Customer: replied 3 months ago.

unit running.

Customer: replied 3 months ago.


Expert:  Wayne replied 3 months ago.

Hi Thank you for that

if both pressures are the same,

that is saying that your throttling valve or unloader in the head is bad,

when did this start

Customer: replied 3 months ago.

we replaced the compressor seal

Expert:  Wayne replied 3 months ago.


What compressor seal ??

Customer: replied 3 months ago.

shaft seal, we trie with other compressor and with have the same problem,

Expert:  Wayne replied 3 months ago.


I have worked on , at TK, Carrier for 34+ years

your front seal has no issue what your problem

that was a waste of time and money

Customer: replied 3 months ago.

I replaced the seal because was leaking

Expert:  Wayne replied 3 months ago.


Still the fact remains,

has no issue what your pressures being equal

front seal just leaks out Freon

I suggest to replace the throttling vale

and head unloaders

Customer: replied 3 months ago.


Expert:  tkman55 replied 3 months ago.

Hi my Name Don are you still in need of help? first check to see if the compressor coupler hasn't stripped out and that the compressor is actually turning. if the pressures are the same on both sides while running and the compressor is turning the compressor has failed and is no longer pumping Freon. Try pumping down the low side front seat the suction service valve ( turn all the way in) and run unit if the unit is still close to the hi side value then the compressor valves are bad

Related Medium and Heavy Trucks Questions