How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 2994
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

2006 Kenworth t-800 tach not working. have signal @obd port.

Customer Question

2006 Kenworth t-800 tach not working. have signal @obd port. tried tach from doner truck still no tach.
JA: Sometimes things that you think will be really complicated end up being easy to fix. The Heavy Truck Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so the Heavy Truck Mechanic can help you best.
Customer: 2006 Kenworth t-800. cat c-15.no tach.have rpm on obd port. tried doner tach.
JA: Is there anything else the Heavy Truck Mechanic should be aware of?
Customer: waiting for further questions.
Submitted: 7 months ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 7 months ago.

My name is ***** ***** I will assist you with your question today.

I'm an independent contractor and I don't get paid until a rating has been made.

We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence!

On the J1939 port, you have a signal? Do you mean you have it with a scanner but you can't get the signal to the cluster?

If that is the case, you have a module programming issue or a bad vehicle module that will need to be swapped and programmed. The engine sends the signal through the diagnostic port to the vehicle module, and then to the cluster module. If wither have mismatched software, you don't get the signal. Same as a damaged harness between the two.

_______________________________________________________________________________

You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see, touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,

they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Expert:  Jeremy replied 7 months ago.

I see you viewed this and this is still showing as an open question due to no positive (3 stars or more) rating.

Were you not pleased with my service to you or is there a rating issue? Please let me know if you still need assistance with this, if there is a rating issue, and/or you need more time to respond.

I like to make sure all my customers are satisfied since you did pay a deposit for me to assist you, whether I’m paid by a positive rating feedback or not.

We can continue where we left off or start over if needed. Also, if you need diagrams, instructions, etc please don’t hesitate to ask.