How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Medium and Heavy Trucks
Satisfied Customers: 24682
Experience:  Performed various automotive repairs on several light duty and medium duty vehicles over 15 years of service.
14928985
Type Your Medium and Heavy Trucks Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 07 flt century with a14l series 60 it has a loss of

Customer Question

I have a 07 flt century with a14l series 60 it has a loss of power that comes and goes last Thursday it was running fine got off the interstate highway step down on the accelerator no power in a few miles it came back ran fine,when I turned into the customers no power changed the fuel filter no change shop said it was the map sensor changed that ran 1/2 day like it should then went to customers to drop trailer now no power after a mile or two it comes back until I slow down and no power
JA: We'll do all we can to help. Is there anything else the Heavy Truck Mechanic should be aware of?
Customer: New fuel filters and map sensor air filter is good
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Heavy Truck Mechanic about your situation and then connect you two.
Submitted: 4 months ago.
Category: Medium and Heavy Trucks
Customer: replied 4 months ago.
Does not show any codes
Customer: replied 4 months ago.
Does it bobtail loaded or unloaded
Expert:  Pete replied 4 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Is there any smoke from the exhaust with this issue here at all?

Let me know so we can continue,thanks Pete.

Customer: replied 4 months ago.
Not that I can tell
Expert:  Pete replied 4 months ago.

Was the injection pump ever tested?I have seen intermittent issues with the injection pump on several medium duty model vehicles in the past that can cause an issue like this here needing replaced.If you did not have this tested (when it is acting up,possibly monitoring the fuel rail pressure on a scan tool/computer plugged into your vehicle) this should be done to see if it is the cause here.

I have also seen restricted dpf filters in the exhaust or converters plug up causing this issue but this is usually all of the time.I suspect more fuel related and may be an issue with the injection pump here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Medium and Heavy Trucks Questions