How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4661
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have a datalink alert on my screen. I have no tach,

Customer Question

I have a datalink alert on my screen. I have no tach, speedometer, oil pressure, or water temperature what could have happened? 99 c112 with M11
Submitted: 8 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 8 months ago.

Hi Jack, my name is***** will try to help. This means either you have lost power or ground to the chassis module or gauge panel. Check all your fuses and relays. Test for power on both sides of the fuses with the key on and replace any that have power on only one side. If okay and its only the gauges you lost and no other functions, verify power and ground to the gauges and inspect the harness and connector pins for damage and corrosion. If you have power and ground and the harness is okay you likely have a faulty cluster. Click below for a company that tests and rebuilds them. Let me know

http://www.instrumentclusters.com/

Related Medium and Heavy Trucks Questions