How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Medium and Heavy Trucks
Satisfied Customers: 25402
Experience:  Performed various automotive repairs on several light duty and medium duty vehicles over 15 years of service.
14928985
Type Your Medium and Heavy Trucks Question Here...
Pete is online now
A new question is answered every 9 seconds

98 c7500 427 no voltage at fuel pump or tbi injectors, truck

Customer Question

98 c7500 427 no voltage at fuel pump or tbi injectors
JA: We'll do all we can to help. Tell me a bit more about what's going on so the Heavy Equipment Mechanic can help you best.
Customer: truck fuel tank got rust cleaned tank replaced fuel pump now willcrank over will start if prime it
JA: Is there anything else important you think the Heavy Equipment Mechanic should know?
Customer: no
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Heavy Equipment Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: Medium and Heavy Trucks
Customer: replied 7 months ago.
still waiting on answer
Expert:  Pete replied 7 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Check for any broken or damaged wiring in the engine bay or leading to the injectors and pump that may need repaired.I have seen damaged/broken wiring cause this type of fault here needing repaired or replaced to correct this issue.If this was already checked and found o.k. let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete