How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 2723
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

I have a 1991 mack truck with a mack pedigree motor beleave

Customer Question

I have a 1991 mack truck with a mack pedigree motor beleave its a 400. part# ***** 3514 and s/n # ***** the vin reads 12mp270c3mmo10947.
JA: We'll do all we can to help. Tell me a bit more about what's going on so the Heavy Equipment Mechanic can help you best.
Customer: The oil pressure sending unit on top of the filters was going out it would shut the motor down so I ordered a new one. when it would shut the motor down I would unplug it .. The truck would start and run but a light came on the dash a lighting bolt looking lite on the dash. The truck would do fine for a while then shut off. So I would plug it back in and it would run. so now it shut down when driving and would not start. I have 50 to 60 running psi 30 at idle oil pressure. It is not getting fuel to the engine supply line big 1/2 inch or so is pumping not a llot of pressure but moving fuel. I cracked the injector lines no fuel. so today the oil pressure sender came in I put it on. still No start.
JA: Is there anything else the Heavy Equipment Mechanic should be aware of?
Customer: sprayed wd-40 in intake seems to want to run so no fuel. do you think computer needs a reset? Is there a way to read blink codes?
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Heavy Equipment Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 5 months ago.
My name is ***** ***** I will assist you with your question today. I'm an independent contractor and I don't get paid until a rating has been made. We can go back and forth as needed to help resolve the issue you are having. Follow ups are free after ratings, so rate in confidence! These trucks don;t do flash codes with the Renault engine that you have. That is who made that engine that you have per the info your provided. You will need the PTT program with the special white face connector to reset the computer on it. If you are still getting the lightning bolt with the shut down, then most likely yes the computer needs to be checked and reset. Are you not getting any fuel from the pump at all? Try putting direct power to the fuel shut off solenoid on the fuel pump for you may have an issue with it and not the computer.__________________________________________________________________________________________________________________________You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see, touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back. Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,they are not the site feedback. Thank you for allowing me to assist you through Just Answer! Jeremy
Customer: replied 5 months ago.
Hello Jerrmy
The fuel solinoid is wide open in the pinch on the highway my mechanic friends took the plunger that opens and closes out knowing we could stall the truck
Customer: replied 5 months ago.
Jermy ill i move through and try the things you suggest and want to leave with the chace to reaume a mechanical conversation in say 24 hrs . I understand the pay ment u need but would like to get all I can before you leave
Expert:  Jeremy replied 5 months ago.
You can return as much as you need to this same question for as long as you need. You can do the payment when we are done or now. It doesn;t matter on that part. Just as long as you are happy and all follow ups are free on this same question. So the solenoid is open, but the fuel is still not getting to the injectors? What about off the pump. Are you getting fuel out of the pump? Are you getting fuel to the pump?
Customer: replied 5 months ago.
Hello jermy
So I had a mechanic scan the computer and he found no active codes ... The one he did think was questionable was Timing speed sensor. ??? Would that shut or not let it start?
We moved on to the fuel pump we made progress there fuel in the line feeding the pump fuel in the rails. Pulled off an injector cam is moving the plungers but no fuel coming out. We beleave the solinoid is out the is on the end of the pump that pushies a plugger in . Manually pushed the plunger in and fuel to injectors. Gonna have the solinoid looked at in the morning.
Expert:  Jeremy replied 5 months ago.
Sounds like the solenoid is bad or power to it is lost. Most likely it is bad. They go out quite a bit. On the timing speed sensor, that can keep the truck from operating properly, but it won't stop the fuel flow. Now if there is no fuel flow and the engine is spinning, that will come up as a fault.
Customer: replied 5 months ago.
The actator is working bench tested and works. Fuel actuator the one that shoves the rack in. Won't do in the rig . What tells it in the truck to work and how do I test them?
Expert:  Jeremy replied 5 months ago.
Do you have power and ground at the plug for the actuator? Which side are you losing?
Customer: replied 5 months ago.
3.68 at the the truck side
Expert:  Jeremy replied 5 months ago.
There is definitely a short somewhere for that should be a solid 12 volts. I just checked Mack and they don;t have diagrams older than 2008. I have an account with Motor Systems and I just emailed them to see if they might have one in their system to provide. They tend to hold onto the older diagrams.
Customer: replied 5 months ago.
Diesel specialist said only needs 3
On the bench it came alive 5.22
Customer: replied 5 months ago.
If your looking at a wiring diagram i see
The 3rd number what it should be in volt s?
Expert:  Jeremy replied 5 months ago.
you have the diagram then... What about ground. Do you have a good ground? Now you bench tested. What it you put the solenoid back on the truck and ran separate power like you did on the bench. Will it move the plunger where you can start teh truck? If not, then if you are getting power and ground, there is an issue with the fuel pump and the plunger...
Customer: replied 5 months ago.
Still no power to fuel actuator
Looking for wire problems
Expert:  Jeremy replied 5 months ago.
Let me know what you find...
Customer: replied 5 months ago.
Looked into the wire loom a couple of bare spots taped them over. Has continuity to bulk head right side all wires from fuel pump area. Still stumped. No troubleshooting guide. Factory wires inside the cab are all black and white
But not actuating the the fuel rack. Basic non active codes. Can the acuator at the pump govenor be hard wired without destroying the actuator it only took 5.22 volts on the bench . Acuator I'm talking about is the rack actuator
Expert:  Jeremy replied 5 months ago.
Use a resistor inline to cut the volts down in half. Radio shack has them and you can hard wire direct to it.
Customer: replied 5 months ago.
No active blink codes to pull. Blink code reader works. So tell everyone you can read them without the ptt. No fuel coming out of rack. Acuator not moving
Again what can make it not work?
Expert:  Jeremy replied 5 months ago.
If the solenoid works and the actuator isn't moving, then the fuel pump shaft is broken and the pump needs to be rebuilt. That is the only other thing that would not have it move. The pump is in 2 parts. You have the solenoid that moved a pin and then the actutator that has a small shaft between it and the solenoid. Since you tested the solenoid to work and still not getting movement, then that shaft is broken or the little pin that holds it in place in the pump is broken. Those pumps have seals and when I get that issue, I send the pump to a injetion shop. I use Acurate Diesel Injection in Orlando, but there may be a shop closer to you.
Customer: replied 5 months ago.
The actuator is not moving
because of no power to it what causes that
I can start it manualy but not with the actuator hooked up.
Expert:  Jeremy replied 5 months ago.
I don't have a diagram older than 2004 in the system. It will be between the ignition switch and the solenoid.
Customer: replied 5 months ago.
I tested the computer work good
can you come up with a better answer than inbetween after all you are getting pais
Expert:  Jeremy replied 5 months ago.
I don't have a diagram for that year. You have to chase the wires througth the harness. You have no other option with this. I am not there and I can;t advise further because I can't see the truck. I haven't been paid a penny for there was no positive rating. This has gone on for 7 days and we are not getting anywhere on this except in circles. I will opt out for I can;t assist you further. Good luck on the repair. If another expert wants to assist, they will come on and assist. Good day.

Related Medium and Heavy Trucks Questions