How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 8454
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
6825259
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

2010 international school bus 6.4l had a fuse due to

Customer Question

2010 international school bus 6.4l had a blown fuse due to shorted wire on injection pump gasket/harness, replaced it and the injection pump, ran great for about 5 minutes then died and won't restart, now I have the code 000164 1 spn engine injection control pressure data valid but below normal operational range- most severe level. Any ideas?
Submitted: 7 months ago.
Category: Medium and Heavy Trucks
Expert:  Wayne replied 7 months ago.
Hi I'm Wayne I will help you with this unplug the ICP, and see if it starts, let me know
Customer: replied 7 months ago.
Do you mean unplug the icp as in the four prong connector that goes to the volume solenoid and the pressure soliniod
Expert:  Wayne replied 7 months ago.
HI Yes unplug it, this will give full pressure
Customer: replied 7 months ago.
I just clipped the wires going to the plug because the plug is to hard to get to without pulling the egr cooler or the turbo, but still no start
Customer: replied 7 months ago.
I just tried a different pcm from another bus, still no start
Expert:  Wayne replied 7 months ago.
HI Sorry for the delay, Site is having issues,could not get to your question to open I would not have cut the wires , but Oh wellyou mentioned PCM, I was talking about the ICP
Customer: replied 7 months ago.
I cut the wires about 6 inches from the injection pump harness that go the the injection volume control and pressure control solinoids still no start, while I was waiting a reply from you I just tryed a different pcm for the heck of it
Expert:  Wayne replied 7 months ago.
Hi Oh OK,Next thing to do is check voltage at the injector plugsmake sure you are getting a good pulse, also you should feel it ticking when cranking
Customer: replied 7 months ago.
Ok I can get to the big plug that goes into the side of the head for the injectors, what should the voltage be
Expert:  Wayne replied 7 months ago.
HI voltage should be battery voltage The Injector Drive Module (IDM), responds to commands from the PCM, ..If the battery voltage during cranking drops below 10.5 volts the IDM relay will shut off
Customer: replied 7 months ago.
Key on engine off voltage should be 12 volts? Or cranking?
Expert:  Wayne replied 7 months ago.
HISorry cranking
Customer: replied 7 months ago.
Shouldn't it be high voltage cranking like 80 to 200v
Expert:  Wayne replied 7 months ago.
NoHigh voltage is from the coil iselfnot going in
Customer: replied 7 months ago.
4 volts koeo, then when cranking it drops to 0volts
Expert:  Wayne replied 7 months ago.
HI Is the ICP wires still cut
Customer: replied 7 months ago.
No
Expert:  Wayne replied 7 months ago.
HI You have no codes correct I believe that you have a wire harness issuecheck that real good for rub marks pinched wires
Customer: replied 7 months ago.
I have the code000164 1 spn
Customer: replied 7 months ago.
Engine injection control pressure data valid but below normal operational range
Expert:  Wayne replied 7 months ago.
HI I would have a good look at the IPR connector and the ICP sensor connectors and check for spread terminals causing intermittent connection . If you have already changed the IPR, ICP sensor and pump , It is likely to be an electrical problem so have a good look at the wiring especially the IPR connector
Customer: replied 7 months ago.
I ohmed the two sensors when I had the wires cut and they both ohmed at 3 ohms
Customer: replied 7 months ago.
Is there a way to get a connector view for the pcm where the sensors go to
Customer: replied 7 months ago.
Or just a terminal number of where the sensors go to, the terminals are numbered but all wires are purple on the hole engine harness
Expert:  Wayne replied 7 months ago.
HI ***** do not have a pin out of the numbers
Customer: replied 7 months ago.
I took the turbo and egr cooler back off to get to the plug on the pump harness everything ohms out good, terminals look good
Customer: replied 7 months ago.
Why do I not have voltage to the injector plug?
Expert:  Wayne replied 7 months ago.
Hi That is from the ecm and gives it signal when crankingit converts from 12v to 110 volts
Customer: replied 7 months ago.
So how do I find out why I'm not getting the voltage to the injector plug
Expert:  Wayne replied 7 months ago.
Hi You need a scan tool, to check this out see if this site helps you click here
Customer: replied 7 months ago.
To command the pressure and volume solinoids to full you have to ground them, unplugging them closes them
Customer: replied 7 months ago.
For your information incase you have someone else with these symptoms, I found that the pcm wasn't sending the ground to the volume control pressure valve, the shorted wires in the injection pump harness shorted also shorting out the Pam, tryed another used pcm and it fixed it
Expert:  Wayne replied 7 months ago.
Hi Glad it is going for you that grounded wire sure caused a issue Wayne

Related Medium and Heavy Trucks Questions