How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 8742
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
6825259
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

Kenworth t660: 2013 kenworth t660. I have no front turn signals.

Customer Question

2013 kenworth t660. I have no front turn signals. The reaer ones work, but the front ones are inop.
Submitted: 10 months ago.
Category: Medium and Heavy Trucks
Customer: replied 10 months ago.
Correction: We have no turn signals in the headlight assembly, we do have turn signals on the corner of each side of the hood.
Expert:  Wayne replied 10 months ago.
Hi "m Wayne I will help yu with this We had a Fleet of KW,very common problem is at the harness at frame and bumper, it wears, and brakes loose , some times hard to find , but that is where it is I hope this helped you Hi. If this helped you Please rate my answer 3 or more stars.If you need more info, use the request button -Not Poor/Bad service.Wayne
Customer: replied 10 months ago.
The wiring is good there. Where to next?
Customer: replied 10 months ago.
We can't find the flasher for the signals. Can you point us in a direction? We have the dash dismantled.
Expert:  Wayne replied 10 months ago.
Hi Sorry fo r the delay It is not the flasher the flasher would not do this if you are sure harness is good then it is the T/S switch it selfI hope this helped you Hi. If this helped you Please rate my answer 3 or more stars.If you need more info, use the request button -Not Poor/Bad service.Wayne
Customer: replied 10 months ago.
There has to be a proper way to diagnose this problem. Putting a TS switch on it without properly diagnosing the problem does not work for me.
Expert:  Wayne replied 10 months ago.
Morning turn key switch to onwith test light/volt meter , probe the t/s switch wire harness, you should have 2 wires blinking whenT/S are on,then go to hood where they are on, and probe the wire to front T/Syour loosing it in that harness

Related Medium and Heavy Trucks Questions