How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4291
Experience:  Owner at DJ Wilson
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have an intermittent engine miss, at idle and under all levels

Customer Question

I have an intermittent engine miss, at idle and under all levels of power. No indication of start or stop it just occurs random and continue for 10 miles or a 100 miles, like it is running on only 5 cyl. All actuators and injectors have been replaced plus many other things. it's like the eng-brk is on as shifting is affected. Motor #14002874. Stuart
JA: We'll do all we can to help. Anything else I can tell the Heavy Equipment Mechanic before I connect you two?
Customer: I'v really been working on this since a rebuild august 2011.
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Heavy Equipment Mechanic about your situation and connect you two.
Submitted: 6 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 6 months ago.
Hi Stuart, my name is***** is the year make and model engine and are you getting any fault codes?
Customer: replied 6 months ago.
Repeating, motor #14002874, ISX 15 LT, 600 HP, 1999 Build year last eight vin# ***** no codes and I have changed almost everything, injectors, actuators, fuel pump, bearings, filters, all fuel lines starting from the tanks and back, lift pump, throttle position actuator, head gaskets and every other thing I can think of even ignition wires. I have not done anything with the engine brake solinoid or internal wireing or ECM
Expert:  Daniel Wilson replied 6 months ago.
Thanks for the update. Check for shorts in the connectors or bare wiring under the valve covers. Cummins insite will be needed to monitor the parameters while driving to help isolate this. Check and see is possibly one of the jakes is hanging up . With Cummins insite you can cut out all except the cylinder you are testing and if the engine stalls instantly that injector is weak. A good injector will try to continue to run before stalling. Check to be sure your ECM is updated with the most current updated software version as well. Install a clear hose inline on the fuel system and monitor for air bubbles just to be sure. Let me know
Customer: replied 6 months ago.
I have done all of those things and as soon as a cylinder-injector shows weakness the others compensate and the indication is lost. I have also located a cool cylinder with a heat gun and replaced one of the new injectors. Even running one cylinder at a time. Same results. I'm not doing this in my backyard all of this has been done at the best four shops in the area. Are we done?
Expert:  Daniel Wilson replied 6 months ago.
Thanks for the update. We can post back and forth as needed. Have you had this on a dyno yet? Oh so you have done a reflash on the ECM? I must have misread. I thought your post said nothing with the jakes or ECM had been done.
Expert:  Daniel Wilson replied 6 months ago.
Hi Stuart, Did you get this resolved or do you still need more help?
Expert:  Daniel Wilson replied 6 months ago.
Hi, Did you get this resolved?
Customer: replied 6 months ago.
You have not touched on anything that I have not already tried.
Expert:  Daniel Wilson replied 6 months ago.
Thjere is no way of knowing that without some follow up from you requesting more information. Did you reflash the ECM yet? I asked but maybe you did not get my response for some reason?
Expert:  Daniel Wilson replied 6 months ago.
Now the other thing that needs to be done is fuel pressure and boost pressure monitored woth a mechanical gauge while driving as well as a clear line installed between the tank and pump and the return to monitor for air bubbles on either the suction or return when this is happening. Let me know
Customer: replied 6 months ago.
I am very busy at this time my work is seasonal with very little time to coridinate with the shop but will try. I have used a site glass in the past and installed a FASS pump air & water filter separator. No change. The problem randomly starts and quits just as random even at idle. It is defineletly worse under power with the actuators making a very loud clatter sound. Like they are dry. No black smoke. Seems to interfere with the shifting as in engine brake on. I have three runs to make between now and Tuesday 4/26/16. Problem causes est 50-100 hp loss motor on dyno puts out 665 hp to ground stock.
Customer: replied 6 months ago.
Dan, a couple more things. The ECM was last flashed in 2013, about 60% on cold start up it will only run on 3 cylinders for a short time 1-2 minutes, I wonder if maybe the ECM itself is bad. What specific locations could air enter the fuel and what are your qualifications / experience. Thanks.

Related Medium and Heavy Trucks Questions