How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4373
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I HAVE 2005 VOLVO WITH D12 ENGINE ITS SMOKING BLACK AND

Customer Question

HI PEARL I HAVE 2005 VOLVO WITH D12 ENGINE ITS SMOKING BLACK AND WHENE I TRY TO TAKE OFF IT DOESN'T GET POWER AND I GOT CODE MID 128 SID 211
JA: We'll do all we can to help. Tell me a bit more about what's going on so the Heavy Equipment Mechanic can help you best.
Customer: THANK YOU...ENGINE DOESN'T GET POWER WHENE I TRY TO TAKE OFF...ITS IDELING FINE
JA: Is there anything else the Heavy Equipment Mechanic should be aware of?
Customer: NO
JA: I'm sending you to a secure page on JustAnswer so you can place the $5 fully refundable deposit now. While you're filling out that form, I'll tell the Heavy Equipment Mechanic about your situation and connect you two.
Submitted: 8 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 8 months ago.

Hi my name is***** will be glad to help. Bare with me while I Pull up your code info

Expert:  Daniel Wilson replied 8 months ago.

ECM

SPN

3510,

Sensor

Supply

V

oltage

2

MID

128 SID 211

Type of fault:FMI

Description:

Fault

Condition:

Possible

Symptoms:

Possible

Cause:

FMI

3

Voltage above normal, or shorted to high source

Circuit shorted +

MIL

illuminated

Incorrect sensor values

Faulty harness or connector

FMI

4

Voltage below normal, or shorted to low source

Circuit shorted

MIL illuminated

Incorrect

sensor

values

Faulty harness or connector

Expert:  Daniel Wilson replied 8 months ago.

Check the harness from the ECM connector for bare or shorted wiring.

Related Medium and Heavy Trucks Questions