How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, Shop Foreman Freightliner trucks
Category: Medium and Heavy Trucks
Satisfied Customers: 4646
Experience:  Shop Froeman for Freightliner Trucks
3506196
Type Your Medium and Heavy Trucks Question Here...
roybelding is online now
A new question is answered every 9 seconds

2010 WS with 60 ser w/ egr dpf, eng # 06R01029777 Truck came

Customer Question

2010 WS with 60 ser w/ egr dpf, eng # ***** Truck came to shop with miss/surge type behaviour... almost like accelerator issues but also does it with hi idle & cruise....checked for fault codes...none... checked for air in fuel...found lots of air coming return line...removed injectors...#3 bypass compression...replaced all 6 cups & injector O-rings....run engine...does same surge/flutter....check for air in fuel again...good...cylinder cut out doesn't produce any results or change....wondering about intake psi sensor..no code..unplug it & produces code but it runs smoother...its so bad...truck can't be used...any ideas ???
Submitted: 9 months ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 9 months ago.

good evening my name is ***** ***** I will assist

the most common issue for this is the delta p sensor. the ports get clogged and the result is your complaint. I would remove the sensor and check the ports all the way down

Roy

Customer: replied 9 months ago.

ok, its not there, has there been an update kit, I think it has but not familiar with it... checked further...yes.. has Detroit update kit #23538485 which has replaced the delta-p sensor & related plumbing.. so inspired to try to unplug the mixer valve in closed position before starting truck....throws code but runs well & smooth as well as boost behaving smooth....plug it in and instantly back to old ways... Now wondering if that valve could be having mechanical issues or why not throwing codes ????

Expert:  roybelding replied 9 months ago.

there needs to be a delta p sensor. who and why did they remove it and what did they replace it with

Customer: replied 9 months ago.

check the Detroit update kit #


18SP654* – EPA07 Series 60

®

Delta Pressure

Sensor Removal Kits

(P/N: 23538484 and 23538485)

That's what is installed on this truck. I don't know by whom but no work has been done on this engine for well over a year. I'm very familiar with pre-EGR Detroits but not these. What or how the new mixing valve is controlled or psi's determined is what I'm wondering ???
Expert:  roybelding replied 9 months ago.

let me do some research on this

Roy

Related Medium and Heavy Trucks Questions