How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4396
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Have a 2005 Freightliner with Eaton Ultrashift

Customer Question

Have a 2005 Freightliner with Eaton Ultrashift RTO-16910B-DM2 that keeps getting stuck in 9th gear (F9 flashes). I have no active or inactive codes. if I reset transmission according to manual, it works fine for a while & then happens again. Any suggestions?
JA: We'll do all we can to help. Is there anything else important you think the Heavy Truck Mechanic should know?
Customer: It seems to only happen with a load of grain on.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Heavy Truck Mechanic about your situation and then connect you two.
Submitted: 9 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 9 months ago.

Hi my name is***** will be glad to help. Bare with me while i gather some information for you to help you troubleshoot this

Expert:  Daniel Wilson replied 9 months ago.

Click on this link and use this procedure and let me know what fault codes you get.

Fault code retrieval

Customer: replied 9 months ago.
I already did that, got #25 (no code) for both the active & inactive codes.
Expert:  Daniel Wilson replied 9 months ago.

What model chassis Freightliner?

Customer: replied 9 months ago.
Vehicle ID#1FVJA6DE75LU69042 Model CL120064S Base Model CL120
Is that what you need? Not sure how to determine chassis model.
Customer: replied 9 months ago.
Engine# ***** Trans# *****
If you need that also.
Expert:  Daniel Wilson replied 9 months ago.

Click on this link and review PDF pages 16-25 and let me know what you get for faults from your dash panel using the procedure in this manual. Let me know what you get for codes from the dash

Manual

Expert:  Daniel Wilson replied 9 months ago.

Manual

Expert:  Daniel Wilson replied 9 months ago.

the links dont seem to be posting. Copy and paste this in your browser if you have to.

http://www.selectruckhouston.com/pdf/New_Folder3/columbia-driver's-manual.pdf

Customer: replied 9 months ago.
When key is on, 2_0.9 comes on then switches to mileage. Doesn't seem to be any abnormal lights. When I cycle the Mode button, Diag 00 shows up. Doesn't seem to show an actual fault detected as per that link.
Expert:  Daniel Wilson replied 9 months ago.

In the manual it says to press an hold the mode button for 3 seconds to select a screen and just pressing the mode button will scroll through. hold the button at Diag and it should bring you to a new screen

Customer: replied 9 months ago.
When I hold button nothing happens, it just stays on Diag 00.
Expert:  Daniel Wilson replied 9 months ago.

Ok thanks for that. I just wanted to see if there were any other codes logged in the Engine ECM etc. It sounds like it might be mechanical with your transmission. Drain the oil in a clean container and look for metal/debris and anything that looks like grey sludge antiseize that would indicate internal problems. This can be caused by a faulty XY shifter or internal wear in the clutching collars which is unlikely for sticking in gear but check inside your filter if you have an external filter kit as well. Let me know

Customer: replied 9 months ago.
I did forget to mention we had a new inertia brake put on a few months ago. And had fresh filters & oil put in when the mechanic changed that out. Could it possibly have anything to do with that? When we asked the mechanic, he said it shouldn't .
Expert:  Daniel Wilson replied 9 months ago.

What engine make/model?

Customer: replied 9 months ago.
Caterpillar C13 Engine #KCB25001 (from manual)
Expert:  Daniel Wilson replied 9 months ago.

it could be possible something from the brake may be affecting this... Click on this link and run through the test procedures covered starting on PDF page 162

Troubleshooting

Related Medium and Heavy Trucks Questions