How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask roybelding Your Own Question
roybelding
roybelding, Shop Foreman Freightliner trucks
Category: Medium and Heavy Trucks
Satisfied Customers: 4639
Experience:  Shop Froeman for Freightliner Trucks
3506196
Type Your Medium and Heavy Trucks Question Here...
roybelding is online now
A new question is answered every 9 seconds

I have 2008 Isuzu/Gmc, model w5500. I have stalling, no

Customer Question

I have 2008 Isuzu/Gmc, model w5500. I have stalling, no power problem with this truck.
I have already changed the accelerator pedal sensor, fuel pressure sensor, fuel pump, glow plug control and still the truck is stalling and has no power. Could you please tell me what could be causing this. The next thing I think on changing is the rail. What do you think.
Please help
Submitted: 9 months ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 9 months ago.

good afternoon my name is ***** ***** I will assist

is this the 5.2 diesel???

are there any codes??? have you checked the fuel pressure???

do you have a scan tool???

Roy

Customer: replied 9 months ago.
is a 5.2 diesel. I have a P0093 code, but we changed the fuel pump already. we have an IDSS11 scan tool
Expert:  roybelding replied 9 months ago.

ok, good. what was the fuel pressure running??? you should be able to see actual fuel pressure.

Roy

Customer: replied 9 months ago.
I see fuel rail pressure at 1.50 in low and accelerated goes up to 3.10
Expert:  roybelding replied 9 months ago.

no, it should be a reading of about 4200lbs. you may be looking at voltages.

it sounds like you have injector issues which is very common. I have done quite a few of these for the code 93. does the engine missfire??

Roy

Customer: replied 9 months ago.
no, no misfire at all. It just looses power while running
Customer: replied 9 months ago.
after changing everything I mentioned before, you think we have injectors problems?
Expert:  roybelding replied 9 months ago.

ok, I still think you have injector issues. I remove them, send them to a machine shop that can clean them and have them pop tested and electrically checked to confirm any failure

Roy

Customer: replied 9 months ago.
what test could we run to be certain we have injectors problems? I just don't want to spend more money without being certain
Expert:  roybelding replied 9 months ago.

unless you have the bench for testing them, that why I suggest removing them and having them tested by someone who can confirm if they are any good

Roy

Expert:  roybelding replied 9 months ago.

how are you making out