How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 8428
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
6825259
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

2015 Kenworth t680 with factory installed battery based APU.

Customer Question

2015 Kenworth t680 with factory installed battery based APU. Espar bunk heater will not come on. I disconnected all batteries to try a reboot. This did not help. The fan does not try to start.
Submitted: 9 months ago.
Category: Medium and Heavy Trucks
Expert:  Wayne replied 9 months ago.

Hi i'm Wayne

I will help you with thi

I am Factory Trained , on APU and the Espar unit

what is it doing, getting smoke , and no ignite

or no smoke, and keeps trying to start

let me know

Customer: replied 9 months ago.
No smoke. No code on the Kenworth thermostat. The fan does not spin at all because I took off the cover to watch it.
Customer: replied 9 months ago.
Of course I don't have the espar code reader.
Customer: replied 9 months ago.
It has been progressively getting temperamental where sometimes it would run and sometimes not. Now it doesn't try at all to fun.
Customer: replied 9 months ago.
To run
Customer: replied 9 months ago.
This is the second winter that we have used it. It has not had any maintenance done to it. We bought the truck new.
Expert:  Wayne replied 9 months ago.

Hi

I am very sorry for the late delay

Grand Kids are over

Ok if you are not getting any smoke then the fuel pump i snit working

2 cause for this, faulty pump, or the silver box, Computer

is not working, , not that it is faulty , just not gettig power

with a test light/voltmeter ,probe all connections, at computer box

you need 3 or more terminals with 12+ volts

and then go to glow plug, and check voltage,

if you do not here the fuel pump start ticking, , the issue is in

Computer box, or connections

I hope this helped you

Hi if this helped you

Please rate my answer 3 or more stars

If you need more info, use request button

Not Poor/Bad service

Wayne

Customer: replied 9 months ago.
No problem for the delay Wayne. I don't think this unit has a silver box as the espar is tied in with the Kenworth factory installed battery based bunk AC unit. I was told that the fan would start to run slowly before the fuel pump would start and the fan doesn't turn at all.
Expert:  Wayne replied 9 months ago.

Thank you for that

Is this a TK Tri Pack or Carrier APU

Customer: replied 9 months ago.
It is a new unit by Kenworth. It comes with 4 extra deep cycle batteries and a Kenworth bunk AC unit that will run up to 12 hours in the battery power. It has an upgraded alternator in the truck as well. The espar is tied into this system. One thermostat in the bunk operates both units.
Expert:  Wayne replied 9 months ago.

Thank you for that

I have never worked on one of them

But did work on Espar heaters ,

1 st the glow plug goes on, ye the fuel pump

starts to pulsate then the fan goes on

but you are getting no smoke so that is no fuel pump

check the voltage at the glow plug when you turn it on

Customer: replied 9 months ago.
OK thanks Wayne. I am on the road with no meter. I think I will try to get it to a Kenworth dealer to read the codes. Thanks for your help.
Expert:  Wayne replied 9 months ago.

Your welcome

there is also a fuse in there for the heater

Expert:  Wayne replied 9 months ago.

should be on the Printed circuit board

of the Apu

Customer: replied 9 months ago.
Ok great thanks Wayne
Expert:  Wayne replied 9 months ago.

Your Welcome