How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4557
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

2007 IH 4300 speedo quit, no ck engine or trans light on,

Customer Question

2007 IH 4300 speedo quit, no ck engine or trans light on, shifts drives fine. service max shows code 639 14 241 254
Submitted: 11 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 11 months ago.

Hi my name is***** will be glad to help

639 14(###) ###-#### ***** Cruise control enable, active, state and vehicle speed not communicated to the ESC PGN 65265-SA 0 Refer to information for the engine in this vehicle in Engine section of this manual ...

Expert:  Daniel Wilson replied 11 months ago.

Check the speed sensor at the tail of the transmission and the sensor harness for damage

Customer: replied 11 months ago.
wires ok, what should the speed sensor ohm out to? also when hooked up with servicemax, I ckd data and of course did not get veh spd reading, but when I switched to Allison doc I get a output shaft speed reading. Is this the same sensor as vehicle speed?
Expert:  Daniel Wilson replied 11 months ago.

I do not have an OHm spec for that sensor as compared to new.... Yes the VSS is the output speed sens.or on the transmission. The ESC is not getting VSS data. Check the harness and if OK replace the sensor

Customer: replied 11 months ago.
ok, will ck tomorrow and let you know
Expert:  Daniel Wilson replied 11 months ago.

Pleasure to help

Customer: replied 11 months ago.
speedo sensor is replaced. still same problem. wire harness looks good. my concern is that the trans ecm reads the speed sensor, and the code indicates engine is not relaying to esc. How can I check this and wiring to it? isn't there some where on diamond logic builder or servicemax that will help me?
Expert:  Daniel Wilson replied 11 months ago.

Thanks for the update. I suggest thoroughly inspecting the wiring and connector pins for damage causing a loss of data link connection. As far as the software the only thing I can think of is you would be loosing signal while trying to read live data for these sensors.

Expert:  Daniel Wilson replied 11 months ago.

Hi, did you get this resolved?

Related Medium and Heavy Trucks Questions