How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Automotive Mechanic
Category: Medium and Heavy Trucks
Satisfied Customers: 25417
Experience:  Performed various automotive repairs on several light duty and medium duty vehicles over 15 years of service.
14928985
Type Your Medium and Heavy Trucks Question Here...
Pete is online now
A new question is answered every 9 seconds

Allison transmission problems. I have a allison 2000 series

Customer Question

Allison transmission problems . I have a allison 2000 series in a 2011 International bus with a VT365 school bus . Last week a driver came in to use bus . Bus wouldn't start dead battery . So they charged it up and started bus . After engine was going a fault error came on the dash saying electrical fault . The bus has a manual shifter not a keypad . Bus would go into reverse hard . Forward gears it would go but slip really bad but would move . There are no back up lights and sometimes it won't start . I thought neutral switch . I used the Allison DOC to see if any codes and it won't connect to the transmission . Is this a power issue or a neutral switch where should I start if it's a power issue where .If neutral switch how do I remove he 2 connectors on the valve body ? This transmission has 150,000 miles on it .
Submitted: 11 months ago.
Category: Medium and Heavy Trucks
Expert:  Pete replied 11 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

This sounds more like a power issue due to loss of voltage possibly.I have seen in some cases where one or more fuses can short out when the battery is recharged due to a voltage surge or spike needing replaced.If you have not checked to make sure all fuses are found to be o.k. this needs done first.If this is checked and all found to be o.k. or was already checked and found o.k. let me know so we can continue here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
I will check that out at work and get back too you ...Thanks
Expert:  Pete replied 11 months ago.

Sounds good.Let me know what you come up with here and if you need anything else.

Thanks Pete

Customer: replied 11 months ago.
I checked all the fuses in the battery box as well as connections . All are tight and clean . I did find loose grounds at the starter .Tightened no change . Do you have any experience with Allisons 1000/2000 series ?
Expert:  Pete replied 11 months ago.

I dont have allot of experience with this model here myself.If you would like I can open your question up for others here to see if anyone else can help further on this just let me know if this is something you would like to do.

Thanks Pete