How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1830
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I am having the same problem and would like the pictures to

Customer Question

I am having the same problem and would like the pictures to repair it
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  diesel-tech replied 1 year ago.

What would you like a picture for?

Customer: replied 1 year ago.
Ok I thought I was going to talk to the gentalmen on the first page. I have a 2007 Gmc c5500 4x4 with the duramax. I am having a problem with the brake switch circuit number 1 in the fuse block keeps blowing. I have replaced to stop switch on the brake pedal. I pull code c0164 and had a c0272 code also. I have unplugged everything on the truck that deals with the brake system from the ebcm to all relays and switches in and outside the cab. It still blows fuse. I have no brake lights do to the problem. I have read on another just ask page about a rewiring of the fuse block to a wire in the relay side. Not sure if this would apply to me but sounds like it is the same problem. It is a gm service bulliten but I can't find the pic for reference. I think the service bulliten is 07-05-22-001 but not sure.
Thanks Bob
Expert:  diesel-tech replied 1 year ago.

The and module is on the driver side of that Truck by the front wheel right ?

Customer: replied 1 year ago.
if your talking about the ebcm yes it is by the front drivers side wheel!
Expert:  diesel-tech replied 1 year ago.

Have you checked the harness going to it for a chafed wire ? I had one run through the harness that runs under the radiator..there is a wire grounding out some were if it keeps blowing the fuse . that is the worst Truck Chevy put out they run the wires over every sharp object the can

Related Medium and Heavy Trucks Questions