How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4400
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have a 2007 Kenworth T 800 electrical problem. The dash

Customer Question

I have a 2007 Kenworth T 800 electrical problem. The dash lights don't work, the tachometer doesn't work, the speedo doesn't work, the fuel gage is stuck on 3/4. That whole cluster isn't working.
Submitted: 11 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 11 months ago.

Hi Jeff my name is***** will be glad to try to help. First test all your fuses on both sides for power with the key on and if any have power on only one side it is bad. If ok you will want to test for power and ground to the gauge cluster by accessing the rear of the panel. If you have power and ground but no working gauges or response the gauge panel is faulty. There are companies that repair and test these clusters. Click this link for one of your options. http://www.instrumentclusters.com/

Expert:  Daniel Wilson replied 11 months ago.

Hi Jeff, did you get this resolved?

Related Medium and Heavy Trucks Questions