How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4741
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I am in a Fuso experiencing problems after putting .80 of a

Customer Question

Hello .. I am in a Fuso experiencing problems after putting .80 of a gallon of reg gas in the tank. Fleet service came out put 4 qts of transmission fluid in the tank also some diesel stabilizer .. He tried resetting the codes but couldn't by taking the battery cables loose .. I got 30 miles down the road started gradually losing power to the point where now the truck will go no faster than 5 mph .. Any suggestions??
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 1 year ago.

Hi Paul, my name is***** will be glad to try to help. What is the year and model of your truck and the engine model number? Also is the check engine warning light on? If so we will need to pull the fault codes which will alert us of the problem circuit. If this is a newer model it is possible the engine ECM has derated your power due to an existing fault. Let me know

Expert:  Daniel Wilson replied 1 year ago.

Hi Paul, did you get this resolved?

Related Medium and Heavy Trucks Questions