How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 4373
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

1994 detroit 60 series miss under load. Miss bobtail but

Customer Question

1994 detroit 60 series miss under load. Miss bobtail but very faint. Sometimes miss at idle sometimes not. I have bypassed fuel lines. I have good fuel psi..ive cleaned all connections on power and negative wires. I bought truck with the issue. I found it had low fuel psi because someone took restrictor out not sure why. Replaced it and psi came up. Done several cut out test. Inj never test same like its jumping around
Submitted: 11 months ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 11 months ago.

Hi my name is***** will be glad to try to help. If the fuel pressure is good and you are not sucking in air ( confirm with a sight glass inline on the suction and return line) then I recommend running the overhead and see if the problem clears up if not then verify the timing is correct and there are no potential bull gear issues and the srs and trs sensors are good not giving erratic signal for engine speed. another potential cause ios worn injectors. Is it throwing any fault codes? Let me know

Customer: replied 11 months ago.
No codes. Overhead has been ran. The srs shows good when on laptop. Never seen a trs listed. I tried adifferant ecm and it ran same. It seems to run good on low side and the first gear in the high side then it starts missing and loses power
Expert:  Daniel Wilson replied 11 months ago.

Thanks for the update and the injector harness checks out good and the connector pins up to the injectors? Have you monitored what the fuel pressure and boost pressure are doing when this start misfiring?

Expert:  Daniel Wilson replied 11 months ago.

Any particular color smoke?

Customer: replied 11 months ago.
No smoke. Other than start up it smokes white till it warms up some. The laptop showed harness is good. Engine was overhauled 15,000 miles ago. Guy said its ran like crap since. But with them changing the return fitting in head its been running on very low fuel pressure since overhauled. Test inj and number six showed badso i replaced it. No change. And the injectors never tedt same from test to test
Customer: replied 11 months ago.
Have notmonitored fuel psi while driving. Truck builds 25-30 boost even while its missing/chugging/fluttering.
Customer: replied 11 months ago.
I was thinkin ng about buying injector oring kit and pop all inj and see if bad oring or badsest washer.
Expert:  Daniel Wilson replied 11 months ago.

That was my next suggestion is injector o rings leaking by or worn injectors.

Expert:  Daniel Wilson replied 11 months ago.

If fuel pressure has been running that low for that long they could have caused damage to the injectors. Hopefully resealing them will take care of it

Customer: replied 11 months ago.
The ecm was updated to a DDEC III. Should injector hieghts be set diff now?
Customer: replied 11 months ago.
Ok. They are set at 78.2 per settings on valve cover. When i do orings ill set them at 78.8. Gonna do that this weekend
Expert:  Daniel Wilson replied 11 months ago.

sounds good. Let me know and it is a pleasure to help

Expert:  Daniel Wilson replied 11 months ago.

Hi Dan, Did you get this resolved?

Customer: replied 11 months ago.
No. Did not have a chance with the holidays
Expert:  Daniel Wilson replied 11 months ago.

Thanks for the update. Keep me posted

Related Medium and Heavy Trucks Questions