How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 9196
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
6825259
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

Hesitation problem with a 60 series Detroit epa07

Customer Question

hesitation problem with a 60 series Detroit epa07
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Wayne replied 1 year ago.

Hi I'm Wayne

I will help you with this

do you get a check engine light on

does it do it all the Time, on straight road or take off

let me know Please

Customer: replied 1 year ago.
Hi Wayne, sorry on the response but truck went out and didn't get back till now. No check engine light but throws an inactive code for turbo, but has a new turbo on it, doing the same with old turbo. Today threw a code for vgt calibration but again was inactive. It does not do it all the time, can get it to do it when sitting with foot or cruise at around 1000 rpm or even 1700 rpm. When driving on road it bucks and sometimes real bad. Still no engine light. This has been doing this since factory, OEM replaced 12 injectors, tested throttle control body, EGR valve, replaced full exhaust system. We tested all the wires going from MCM to VGT with a lamp and it powers up lamp, checked all cables, powers and grounds, went through majority of wiring, we checked parameters(good), program seems to be ok can't see nothing out of the ordinary. Look forward to hearing from you
Customer: replied 1 year ago.
Sorry Wayne , My name is Patrick
Expert:  Wayne replied 1 year ago.

Hi Patrick

good to hear from you

when you mention , been doing it from OEM

are you saying a new truck , under warranty ??

let me now

Customer: replied 1 year ago.
No truck is a 2009, just problem exists since
Expert:  Wayne replied 1 year ago.

Morning

Everything checked good , and you checked all possible cause

The only thing left in my opinion

is a glitch in the ECM

Related Medium and Heavy Trucks Questions