How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 1634
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Problem #1 2007 Columbia Freightliner over heating. Pulling

Customer Question

Problem #1
2007 Columbia Freightliner over heating. Pulling a heavy load 44000 lbs. Noticed a few weeks ago that seemed like I was adding coolant more often during pretrip. Made a mental note to keep eye on it. I usually pull much lighter loads but today got stuck with load 44000 lbs. Coolant legal was fine when I did PM this morning but after picking up the load the truck started over heating figured it was just the weight of the load its and older truck with(###) ###-#### ***** on it. Have had to add 2.5 gallons of coolant today and had so sit on side of road several times to let truck cool of as Service Engine light came on and Engine protect warning. I am not leaking any coolant on ground butvi keep having to add and don't know where it is going. I also don't have a Engine fan over ride switch to help with the cooling. Any Ideas what the problem might be?
PROBLEM #2
Having an electric problem with same truck. Keep losing my marker lights on truck and trailer. Taken it to several TA shops on the road and the can't seem to find the problem. The problem is intermittent but reoccures a few miles down the road. Had the trailer check and they found problem with the trail but then I took my truck bobtail for a drive 8 miles and my marker went out. Then there was like all my breakers were poping in my circuit panal so I turned truck off headed back to truck stop and before I got there the makers on truck started working again. Had one machanic replace pig tail and another replaced Headlight marker switch in dash problem fixed NO still doing it do you have any idea what's causing this problem?
Submitted: 11 months ago.
Category: Medium and Heavy Trucks
Expert:  roybelding replied 11 months ago.

good evening my name is ***** ***** I will assist

is there any smoke out the exhaust???

do you have an egr???

Roy