How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 2783
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

Truck will not run when first started sounds like starving

Customer Question

Truck will not run when first started sounds like starving for fuel was told it was one of those electric plugs on the side of the fuel pump called a v voltage
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 1 year ago.

My name is ***** ***** I will assist you.

Sound like you are describing the lift pump acting up. someone must have told you to check for VRef voltage at the side of the pump. That is what it sounds like to me.

I saw your other question about the same engine where you are having idling issues, but running the engine is good. I would agree with who you talked to about the lift pump. It sounds like your lift pump is bad and needs to be replaced.

__________________________________________________________________________________________________________________________
You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,
touch, smell, hear, or taste the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

The system DOES NOT automatically give me credit from your deposit. A rating is REQUIRED. You are rating me for the information I provide,
not the website. I have no control over the site fees, site errors, category errors, or how long it took for a response for these reasons.

I am not an employee of this website, so please rate with a POSITIVE (green) rating for me to get credit for assisting you. You still pay
the website for negatives or by not rating at all. I just get nothing from that payment you made. So please rate each answer I provide.

I want you pleased with my service to you so please inform me before rating negative (red) and I will do my best to make it right. Follow
ups for same question are always free after ratings have been made.

I do have many workshop manuals, diagrams, etc that I pay to get access to out of my pocket. If one is needed, please ask and I will give
you an offer at my technician discounted cost to you for such manuals. I never charge above that cost.

Thank you for allowing me to assist you through Just Answer!

Jeremy