How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 2547
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Medium and Heavy Trucks Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

Clayton. Have a 2000 Setra S217 bus that randomly shuts

Customer Question

Hello Clayton. Have a 2000 Setra S217 bus that randomly shuts down, and won't start. Has a series 60 engine with ddec IV. Red engine light comes on and shuts off as normal, but won't start. I disconnected the fuel line at the primary filter, but fuel dribbles out slowly. Should the gravity system come out faster, or am I going in totally the wrong direction?
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  spankyjr1 replied 1 year ago.

Good morning, sorry for delay, my name is ***** ***** you for asking your question, I will try and help you out.

Clayton has not been online for a couple months would you still like assistance with this?

When it does not start does it crank over?

When it does not start does check engine light come on and go off with ignition turned on?

Try and pull codes using cruise switches if you don't know how here it is below

Use the following procedure to retrieve the flash codes from the check engine light:
Turn the ignition key switch to the On position/ Engine OFF.
Turn the cruise control ON/OFF switch to the OFF position.
Move the SET/RESUME switch to either position. Hold that position until the yellow lamp begins to flash.
The yellow lamp will flash in order to indicate a two digit flash code and the SET/RESUME switch may be released.
The sequence of flashes represents the system diagnostic message. Count the first sequence of flashes in order
to determine the first digit of the flash code. After a two second pause, the second sequence of flashes will identify
the second digit of the flash code.
Any additional flash codes will follow after a longer pause.
It will keep repeating codes until you turn off key.
Any questions just let me know.

Customer: replied 1 year ago.
It turns over but only fires up with ether. The check engine light comes on and goes off after about 5 sec. I tried to pull the codes but nothing happens. The cruise switch is a four way lever on the steering column. Up and down is on and off. Left and right is set and resume. No combination makes it flash codes. I did not see any other cruise control switches on the dash. I put a jug of diesel right after the first fuel filter, and it does suck fuel when you turn it over.
Expert:  spankyjr1 replied 1 year ago.

You need to put 5 gallon bucket of fuel before fuel pump on back of compressor,,, bypassing filter head,,use line that goes to first filter,,then crimp return line off at back of trans coming from cylinder head,,, not all the way,, it must allow some fuel through to bleed air.

Is tach moving?

Customer: replied 1 year ago.
Tach doesn't move.
Expert:  spankyjr1 replied 1 year ago.

That's your issue replace both crank and cam sensor!

Cam sensor on this is called synchronous reference sensor and is mounted below air compressor.

Neither one needs to be set.

I always replace them as a set to avoid issues down the road with the other one failing.

Please take a moment to rate my service so that I can get credit for my time from the web site.
The question will still remain open for follow up questions if needed.
Thanks
spanky

Expert:  spankyjr1 replied 1 year ago.

Going out to cut grass so if you need anything else I will reply when done/

Thanks

Customer: replied 1 year ago.
you're saying that would make the bus sometimes run and sometimes not? It used to run then would randomly shut off and now not start at all?
Expert:  spankyjr1 replied 1 year ago.

Yes it would,,it would also cause the engine light to come on and not restart.

When the sensors get weak you can crank all day and it won't start,,its starts off being intermittent until it finally fails altogether.

Customer: replied 1 year ago.
How can I replace them with common tools?
Expert:  spankyjr1 replied 1 year ago.

Those sensors tell the ecm to apply power to injectors,,if it does not fire injectors you get no fuel.

Yes common tools will replace sensors nothing special needed.

The sensor below air compressor after removing the one bolt,, turn sensor to loosen and pop out with screwdriver,,a o-ring seals it from leaking and can cause it hard to get out,,if you turn first it should come right out,,spray some lube if you like..

Customer: replied 1 year ago.
Can I just do one of them for now?
Expert:  spankyjr1 replied 1 year ago.

Its up to you I would replace both if you are only going to change one I would do the one under compressor

Customer: replied 1 year ago.
Will one work without the other for now? I'm just on the side of the road and towing wants $400.
Expert:  spankyjr1 replied 1 year ago.

The one under compressor is needed to tell ecm what stroke the engine is on,,the crank being bad would cause long crank times but should run without crank sensor after using ether to get going.

Customer: replied 1 year ago.
Which sensor is under the compressor so I can buy that one?
Expert:  spankyjr1 replied 1 year ago.

SRS = synchronous reference sensor

Customer: replied 1 year ago.
I'm looking online for pictures on how to remove it. If this fixes the bus I'll take care of you man!
Expert:  spankyjr1 replied 1 year ago.

Look on page 4 it shows both SRS and TRS Timing reference sensor

Expert:  spankyjr1 replied 1 year ago.

TRS is Crank sensor

Customer: replied 1 year ago.
I saw the crank sensor but can't see the srs sensor. Is it in the location in your manual because it's impossible to see.
Customer: replied 1 year ago.
The SRS sensor is not in the location your drawing describes. Is there another spot it could be?
Expert:  spankyjr1 replied 1 year ago.

Please get me the model and serial number of engine?

Is this a V engine?

Customer: replied 1 year ago.
I'll get the serial number tomorrow.
Expert:  spankyjr1 replied 1 year ago.

And model number please,, both are on same tag.

The 60 series always to my knowledge has the SRS sensor in that location, so I don't understand why it would not be there.

The TRS did change through the years but not SRS.

Talk tomorrow

Customer: replied 1 year ago.
The TRS was there. The SRS was not. It is a 2000 model year bus so I'm not sure myself either.
Expert:  spankyjr1 replied 1 year ago.

That's why I need the model number to double check.

Expert:  spankyjr1 replied 1 year ago.

Actually above the compressor another engine is below DD60 has always been in same place here is a older one click here

Customer: replied 1 year ago.
Here is the plate on the engine which is hard to read.
Customer: replied 1 year ago.
Much better picture.
Expert:  spankyjr1 replied 1 year ago.

The picture I showed you was correct then srs is just above air compressor,,if you don't have a air compressor above fuel gear pump which is normally mounted to back of air compressor.

SRS is located on left side of engine when viewing engine from the rear,,srs is on block side of front cover just below valve cover.

Send me a pick if you can't find it

Customer: replied 1 year ago.
I had a mechanic check that engine and he called Detroit and they said it doesn't have an srs sensor for that year. He said Detroit told him they didn't start using those until 2004. Can you confirm?
Expert:  spankyjr1 replied 1 year ago.

That's a 2003 book and I went back to a 1998 book and it's the same engine 12.7 liter.

Expert:  spankyjr1 replied 1 year ago.

Send me a picture of what you have,, right where I said to look.

I never seen one without one but if it does not have one replace trs

The ecm needs to know what stroke its on to fire injectors

Customer: replied 1 year ago.
I have a mechanic there now and he took the belts off and everything and said the sensor is not there. Where else could it be?
Customer: replied 1 year ago.
Trs was there. Been replaced. Still not starting.
Expert:  spankyjr1 replied 1 year ago.

Loosen the fuel line after fuel pump,,the smaller line on pump going to secondary filter,,crank over and see if it blows fuel out

Expert:  spankyjr1 replied 1 year ago.

Tach still not moving?

Check ecm fuses,,, there are two,,they are either by batteries,,ecm,,or starter.

If by ecm may be behind wiring.

Customer: replied 1 year ago.
Here are the pics behind the compressor.
Expert:  spankyjr1 replied 1 year ago.

What about the rest of my questions and did you check for fuel?

I'll look at another book the only other place I've seen them is on front cover,,bellhousing so it can pick up off the flywheel,,or on side of engine above oil pan a couple inches,,either side.

It must be something different because its a bus

Customer: replied 1 year ago.
I'm having them check the fuel now.
Expert:  spankyjr1 replied 1 year ago.

okay,, did he look by crankshaft left side of engine below trs

Expert:  spankyjr1 replied 1 year ago.

Look by crank on front cover there may be one there

Customer: replied 1 year ago.
Not there
Expert:  spankyjr1 replied 1 year ago.

other questions need answered in case its not a crank/cam sensor issue!

Expert:  spankyjr1 replied 1 year ago.

I' almost done for today so need soon

Customer: replied 1 year ago.
Wating for reply.
Customer: replied 1 year ago.
Ok
Expert:  spankyjr1 replied 1 year ago.

From mechanic?

Customer: replied 1 year ago.
Fuel flow is good. Tech says injectors not firing.
Expert:  spankyjr1 replied 1 year ago.

http://www.ddcsn.com/cps/rde/xbcr/ddcsn/1-SECM-03-03.pdf

this is a different series but under or by starter almost last page

Expert:  spankyjr1 replied 1 year ago.

Take a look at other things I mentioned above,,check injector harness for any rubbed through spots,,

I'll send a buddy of mine who works on a lot of buses a email see if he can help us out.

Make sure coolant level is full jump out sensor and try again.

If you have a override switch/button or diagnostic switch hold that with key on to get codes! count flashes

I still need other answers please go through our conversation and finish answering

Talk later

Customer: replied 1 year ago.
The tech is leaning towards ecu or bad ecu harness. I may run fresh power to it myself to check if the wiring has gone bad as I've seen that online as being a problem frequently. If it was cool and it would start and run for 30 sec. I'll be there myself in about 7 hours to confirm everything else.
Expert:  spankyjr1 replied 1 year ago.

It could be but doubtful that usually causes mis first.. do you have a override button to get off road or a diagnostic switch?

What about the two fuses?

What about tach?

I need all the info to help out plus I sent a buddy a email he usually gets back to me pretty quick.

I do have Church so will be gone for a few hours I will reply when I can

Expert:  spankyjr1 replied 1 year ago.

It could be injector drivers in ecm but does not explain no tach!

Customer: replied 1 year ago.
I'll check the two fuses again myself also. You also said the override button may give me codes?
Expert:  spankyjr1 replied 1 year ago.

Load test the power coming from two fuses with a headlight,,, fuse out on hot side of holder! if light is not bright clean batts first.

Yes if you have a override button,,key on,,engine off,,hold down button 5 seconds until check engine light flashes,,count flashes for first number of code,, short pause,,, second number,,then it repeats or goes to next code,,when done it will keep repeating until key off

Customer: replied 1 year ago.
Is this a 24v ecu or 12v? Seeing which voltage headlight I need.
Expert:  spankyjr1 replied 1 year ago.

I just got a email back from my buddy and he says what I told you earlier :::Make sure coolant level is full,,, jump out sensor and try again. Use a paper clip!! 01/11/2015 03:30

On these the low coolant level will keep engine from starting,, so even if its not low jumping sensor will tell you if sensor is bad!!

Use volt meter to check voltage at fuse they can be wired either way!!

He also said this ::It is a Sentra Bus (wired totally differnent) which is now made by MCI - he can call them - free tech support with VIN number

It would be nice if you rated my assistance thus far,,,,,,, you can still follow up here if needed.

You already paid the site for asking the question,,but they don't pay me until you rate me with smiley faces for all my time,,

Related Medium and Heavy Trucks Questions