How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8681
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

A C7 THAT HAS TO MUCH VOLTAGE AT THE OIL RAIL SENSOR ABOUT

Customer Question

Customer: A C7 THAT HAS TO MUCH VOLTAGE AT THE OIL RAIL SENSOR ABOUT 5.6 VOLTS AND TO MUCH OIL PRESSURE IN THE HEAD CRANKING ABOUT 5000 PSI SERIAL NUMBER KAL87884
JA: Thanks. Can you give me any more details about your issue?
Customer: It starts and runs but bucks bad and sometimes has code 164-3 and 15 and once a 164-11 I changed the actuation pressure sensor this week and pump about 3 or 4 months ago. The injectors have been checked and 4 have been replaced
JA: OK got it. Last thing – JustAnswer charges a fee (generally around $54) to post your type of question to Heavy Equipment Experts (you only pay if satisfied). There are a couple customers ahead of you. We can help you for less if you're not in a rush. Are you willing to wait a bit?
Customer: Yes if necessary. I have used you guys before. Would like to get it today if possible.
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 1 year ago.

Thanks for asking your question and requesting me. I will try and help you out.

It's acceptable to have 4.5 to 5.6 supply voltage to the A wire on the IAP sensor.

Are you reading the 5000 psi on a manual gauge? Or on ET status screen?

Does the engine not start? Are there any codes?

Customer: replied 1 year ago.
I guess I misunderstood I thought that that voltage was high. The 5000 psi is cranking it over with a gauge in the head. It does start and run. If you do not drive it you would not know it has any problem. When you drive it and you get going and get about 4th or 5th gear it will start bucking so hard it will break something if you do not let out of it. It is the worse when it is in the torque curve from mid to high. It has had code for injection actuation voltage high 15 one time it had boost pressure not responding but I can not make that repeat and 164-11 actuation pressure system fault 39 and have not had that repeat. I may need to drive it again to recheck they seam to only come on well driving.
Expert:  Cat Man replied 1 year ago.

Thanks for the information.

If the pump pressure is at 5000 psi at all times. The heui pump is bad and stuck high. I've seen this many times.

Many times when the heui pump fails it make low or no pressure. But sometimes it gets stuck at max pressure. There is nothing else that can cause the pressure to go to 5000 other than a bad heui pump.

Please reply back if you need more help or have more questions. I am happy to assist.

Expert:  Cat Man replied 1 year ago.

Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.

Related Medium and Heavy Trucks Questions