How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Andy Your Own Question
Andy
Andy, Truck Diagnostic Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 1571
Experience:  International trucks, International, Maxxforce and Cummins engines, diagnostic, electrical, Hvac and refrigeration repairs
30303843
Type Your Medium and Heavy Trucks Question Here...
Andy is online now
A new question is answered every 9 seconds

04 IHC 4300 DT4600 engine starts runs 5 minutes stops and

Customer Question

04 IHC 4300 DT4600 engine starts runs 5 minutes stops and wont restart until engine is cold. replaced relief valve and all 6 injectors
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 1 year ago.

My name is ***** ***** I will assist you.

Your bus will not be the same as the Columbia. That bus model and year is the same as the M2. I am attaching the transmission interface diagram. See if this is what you needed.

__________________________________________________________________________________________________________________________
You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,
touch, smell, hear, or taste the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

The system DOES NOT automatically give me credit from your deposit. A rating is REQUIRED. You are rating me for the information I provide,
not the website. I have no control over the site fees, site errors, category errors, or how long it took for a response for these reasons.

I am not an employee of this website, so please rate with a POSITIVE (green) rating for me to get credit for assisting you. You still pay
the website for negatives or by not rating at all. I just get nothing from that payment you made. So please rate each answer I provide.

I want you pleased with my service to you so please inform me before rating negative (red) and I will do my best to make it right. Follow
ups for same question are always free after ratings have been made.

I do have many workshop manuals, diagrams, etc that I pay to get access to out of my pocket. If one is needed, please ask and I will give
you an offer at my technician discounted cost to you for such manuals. I never charge above that cost.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 1 year ago.
I did not receive an answer to my question
I want engine answers not transmissiom
Customer: replied 1 year ago.
I still need an answer
Expert:  Jeremy replied 1 year ago.

There must be a glitch in the system for I never saw or responded to this question. My response I have on there is to another customer I've been working with all day... I will have to report this glitch.

I apologize that the system glitched on you. The person you want is Andy who is the International dealer expert. I will opt out of this since the system glitched and put my repsonse of another question on here.

He should be along shortly.

Expert:  Andy replied 1 year ago.

Hi there ! My name is Andy ! Can you tell me which codes are active in memory after that 5 minutes of run time ? When it shuts down ? Here is the procedure to check flash codes .

https://www.dropbox.com/s/f526i7b69ifw887/How%20to%20check%20codes%20three%20digit.txt?dl=0

Customer: replied 1 year ago.
The codes are 144, 143, 112
Expert:  Andy replied 1 year ago.

Thanks for the info!

Expert:  Andy replied 1 year ago.

Sorry for the delay ! Issues at home . Will look these codes up now.

Expert:  Andy replied 1 year ago.

143 - Incorrect CMP signal signature

Expert:  Andy replied 1 year ago.

112- Electrical system voltage B+ out-of-range high

Expert:  Andy replied 1 year ago.

Does this engine have EGR on it ?

Expert:  Andy replied 1 year ago.

Scratch the last post ! This unit does not have EGR .

Expert:  Andy replied 1 year ago.

144- cam position signal noise detected

Expert:  Andy replied 1 year ago.

Sounds like you have cam position sensor issues. Have you tried another sensor ?

Related Medium and Heavy Trucks Questions