How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8717
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

Mr. Cat Man, We have a c13 ESN:LEE___ that is in a tour bus.

Customer Question

Mr. Cat Man, We have a c13 ESN:LEE___ that is in a tour bus. We recently replaced the camshaft and and a few other thing and put it back on the road. We now keep getting the code of 3703-31. This bus does not have have an inhib switch and only a spring loaded toggle switch at the rear of the bus near the engine. You can flip the switch up to inhibit and or down to disable. Can you give me any insight on this issue.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 1 year ago.

Thanks for asking your question. I will try and help you out.

This code only comes up when the engine needs to perform a regen and it is detecting a switch in the inhibit position. I would first go to status and see if the ECM is seeing the switch on. It could be a wiring or switch problem. If there is no inhibit switch. You would need to go to the configuration screen and change the programming to off or none to tell the ECM there is no inhibit switch.

Please reply back if you need more help or have more questions. I am happy to assist.

Customer: replied 1 year ago.

I can't seem to find the switch under status but like i said it does not have have a swtich on the dash. Just at the rear of the bus inside the engine compartment

Expert:  Cat Man replied 1 year ago.

I see. The switch may not be in one of the groups. You may have to create a new group and find it from the list. Not all items are in a group.

Customer: replied 1 year ago.

This switch would have to run straight to the ECM right?

Expert:  Cat Man replied 1 year ago.

Yes sir. That is correct.

Customer: replied 1 year ago.

ok the switch at the rear of the bus toggle up for initiate and down for disable. I flip the switch up and it starts the regen but after a few min quits regen because of inhibit switch. There is clearly no switch. How could it give me this code if the engine doesn't have the switch.

Expert:  Cat Man replied 1 year ago.

I see. That is very strange. Take a look in configuration and see if it's programmed for an inhibit switch. If it is. I would turn it off.

Customer: replied 1 year ago.

This bus is definitely not programmed for an inhibit switch.

The last few times i've tried to do a regen with et it just kicks out and says failed to ignite but fault codes to say why.

With the key on and engine dead should the spark plug be sparking?

Customer: replied 1 year ago.

Also....what if the engine didn't need a regen, would it still allow it to do so?

Expert:  Cat Man replied 1 year ago.

If the engine did not need a regen. It will not allow one to be performed. With the key on and engine off, I do not believe the spark should be sparking.

This is starting to look like an ECM problem is there is definitely no inhibit switch. I have never seen an ECM do this but if there is no inhibit switch and it is not programmed for one. Sound very odd.

Customer: replied 1 year ago.

Mr Cat Man, I noticed this morning when trying to do a regen again that the ARD fuel pressure, ard pilot pressure, and ard fuel pressore control command percentage all stay on 0. What should those values be?

Expert:  Cat Man replied 1 year ago.

Are they all at 0?

Customer: replied 1 year ago.

All three that I mentioned...YES. I know my spark plug is firing for sure. But don't think i'm getting any fuel. I did change one of the valves on the manifold. I believe it was VALVE GP-SOLENOID(ARD MAIN FUEL).

I only changed it because we accidentally cut the wires on it it.

This bus is killing me!! lol I appreciate all your help!

Expert:  Cat Man replied 1 year ago.

Thanks for the information. If they are all at 0. It sounds like it's definetely not attempting a regen. If it were. You should see the pilot fuel first along with fuel command. Then after a few minutes the main fuel should come on. Pilot pressure should be between 230-250. Main should be around 25 psi.

Customer: replied 1 year ago.

would you recommend changing the rest of the sensors and other valve in that fuel manifold?

Expert:  Cat Man replied 1 year ago.

What codes do you have? Just the 3703-31?

Customer: replied 1 year ago.

Yes that is the only code im getting and i have talked to the factory that build this bus and they have ensured me this bus does not have an inhibit switch. I did get a failed to ignite code once but i think that might be because i had some wires swapped. I'm wanting to think there is no fault for whatever kinda odd issue we have going on here and the only thing the ecm knows to do is throw the code for inhibited.

Expert:  Cat Man replied 1 year ago.

You may be correct. The engine does not want to regen or else there would be a 3719 code. I think the system is fine but I can't explain the 3703. I would let them have it and try it

Expert:  Cat Man replied 1 year ago.

Hey. I just wanted to see how things were going. Please let me know if you need more help. I am happy to assist. If my information was helpful, please leave a good or higher rating so that I receive credit. Thanks.

Related Medium and Heavy Trucks Questions