How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 2518
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Medium and Heavy Trucks Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

I replaced coolant sensor in t800 and light went out miles

Customer Question

I replaced coolant sensor in t800 and light went out for 2 miles is all, took plug apart and hooked it up with just wires and it worked for 3 minutes
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  spankyjr1 replied 1 year ago.

Good morning, sorry for delay, my name is ***** ***** you for asking your question, I will try and help you out.

If the old sensor failed and the wiring was wet the wiring harness will need to be replaced.

When that happens it allows coolant to penetrate into wires (water intrusion) and changes the resistance the ecm sees and keeps coding out. You could just try a new plug it comes with wiring kit for coolant sensor wiring replacement.

The only other possible problem is the wiring harness may be rubbed through somewhere so it would need repair or replacement.

Thanks

spanky

Expert:  spankyjr1 replied 1 year ago.

Would you please rate positively or accept my answer,,, if you don't the website does not share the fee you paid with me for assisting you.

Thank you

Related Medium and Heavy Trucks Questions