How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cat Man Your Own Question
Cat Man
Cat Man, Cat Engine Expert
Category: Medium and Heavy Trucks
Satisfied Customers: 8412
Experience:  I am ASE Master Truck Certified.
30708357
Type Your Medium and Heavy Trucks Question Here...
Cat Man is online now
A new question is answered every 9 seconds

I have 20 psi at start up cold. warm engine and rev it up

Customer Question

I have 20 psi at start up cold. warm engine and rev it up and it drops to 10-15 psi. just completed a out of frame on it and still have the same issue. any suggestions.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Cat Man replied 1 year ago.
Hi. Thanks for asking your question and requesting me. I will try and help you out.
Was the engines oil filter base or engine oil pump replaced with the overhaul?
Did the engine have low oil pressure before the overhaul?
Customer: replied 1 year ago.
yes to both questions
Expert:  Cat Man replied 1 year ago.
Thanks for the information.
It's common to get low oil pressure on these engines. I have seen it many times.
The most common things that cause the low oil pressure are the oil pump and the oil filter base assembly. The relief valve has been known to rub and get damaged and stick open. I have had to replace many of these for low oil pressure.
If you have replaced these and still have low oil pressure. There are two other things I would suspect.
Cam bearing wear or a problem with one of the piston cooling jets. I have seen them get hit or break off and lower oil pressure.
Please reply back if you need more help or have more questions. I am happy to assist.
Customer: replied 1 year ago.
we have checked the bearing and jets.
Expert:  Cat Man replied 1 year ago.
Thanks for the information.
If the jets and cam hearings are ok. I must suspect a leak or defect in the block. It's possible the Problem could be in the head but since it was replaced I would not suspect it.
There could also be a leak on the overhead on the Iva housings.

Related Medium and Heavy Trucks Questions